Return to Level1Techs.com

Desperate Linux fan needs some help... V-V


#21

Could you try it with a different USB drive or with a CD/DVD?


#22

I would if MSI did not suck so bad… (what was on the board is the latest still)


#23

I have an MSI board so I have some experience with dealing with their BIOS’s.


#24

You could try to flash it again.


#25

Any idea what settings can cause it to have USB failure when running any Ubuntu based OS later than 16.04?


#26

USB failure occurs if the flash was bad or it has bad boot sectors (usually).

Is this when you try to auto boot or when you manually select the bootable USB on the splash screen?


#27

A re-flash? I rather avoid that… (finding a new MSI 970 Board or other 970 or 990FX board is not as easy as it was…


#28

If your BIOS was bad it wouldn’t POST at all. So I don’t think you need to reflash your BIOS, just the USB drive.


#29

Last time with latest Linux Mint? Well it happened right after I had rebooted it and installed Steam + Discord I then were gonna download some games and… OwO


#30

Wait, drive? I thought this is about USB-ports.


#31

Okay you’re kind of going all over the place.

In this instance, when you try to boot to the imaged flash drive, you get that error saying it is bad yes?


#32

Nope its after the install and I am trying to use it the ports just die, then to fix it I most do a CMOS reset or else it follow me onto the Windows drive, I am not sure but it seems the clocks of the CPU is raised a bit to.


#33

Okay, so the issue is that after installing linux of choice, the USB ports on your case no longer work?


#34

Those never worked in Linux, its the ones to the board that stops working! XD (what Barbarian would plug the keyboard and mouse to the front ports?) :stuck_out_tongue:


#35

It sounds likes its not registering the firmware.

Are you updating your system post installation?


#36

Yeah that I tried sometimes it finishes the update before during the USB failure…


#37

It is just the front, or is it both the USB headers on the front of the case and on the rear I/O which seem to go out quasi-randomly?


#38

Motherboard ones, the ones on the case never ever wanted to work with Linux even in 14.04. OwO


#39

14.04 is about to be deprecated, but it stopped receiving hardware updates in late 2016. That said, your hardware should work since it was in circulation circa 2016, sans the Vega 56.

What happens if you try to install ubuntu 16.04? My guess is if there was specific fixes for your hardware configuration they might exist in that release.


#40

Directly without upgrading from 14.04? Same shit as 18.04, USB dies while trying to use it and I most reset CMOS. I am quite sure its not the board since long ago on the LTT forum around 6 months ago someone else with a AMD 970 board told he had same issue he just decided to stick to 14.04 until he got a Ryzen… -3-