Return to Level1Techs.com

Desperate Linux fan needs some help... V-V


#1


Original post above told me to ask here since this forum is way more into Linux, trying to make it a short story I had 14.04 updated(not to 16.04 just regular update) it I ended with a wall of text unable to get into desktop. I then tried to re-install with anything above 16.04 to 18.04 and all has the same bug the USBs stops working or everything just freezing up, then I was thinking maybe it was due to Nvidia so I ditched my GTX 970 and upgraded to the RX Vega 56! Did that solve anything? No. Now I cannot even use 14.04 since I cannot install the bloody drivers on it and I can get 16.04 to work if I upgrade from 14.04 which is odd but still same issue cannot get the damn drivers to work. https://www.youtube.com/watch?v=jUXcvZ9TAsE & some other tutorials all ending up failing, one thing I tried was to install a APU driver which worked better than nothing but then crashes every time under load. After so many re-installs and fails I am still stuck at the USB failing and it will not even work in Windows until I reset the CMOS so any ideas? O3O (been stuck with this issue for 6 months!)


#2

If it is happening on any OS, are you sure it’s not faulty hardware?

Speaking of hardware… well, what is it even?


#3

FX-8370, MSI 970 AM3+ board & RX Vega 56 there is no problems in WIndows, it only happen in Ubuntu 16.04 and later, 14.04 is fine but there is the driver issues and same goes if upgrading to 16.04 then its only driver issues and I am not sure how it works when I upgrade from 14.04 rather than installing 16.04 directly… :S


#4

Have you tried another Linux Distro than Ubuntu?Maybe the problem is just Ubuntu related.
If you want RX Vega, you should use a kernel newer than 4.15, better use 4.18, as there were substantial improvements in the kernel for Vega cards.


#5

Any tips of which Linux distros that are good for a Steam + Discord system? Anyhting that is easy mode would be nice and not based on Ubuntu, Linux Mint has same issue…


#6

Manjaro. I’m not using discord but everything else fits the bill.


#7

I use manjaro too, and discord works fine, you can install it from the AUR


#8

I was just going to say the same, Manjaro. If you still don’t have any luck with that give TrueOS a shot, it is based on FreeBSD, and will give you an idea if it is just a thing with Linux. First I would try resetting your settings in the BIOS to default, then install your choice of Linux. I have had issues installing before because of certain settings in my bios.


#9

I hesitate recommending Solus since the head developer just left, but it might be a good fit here.


#10

I did try to reset the CMOS but some settings I do not think are being reset, is there a way to know if stuff such as spreadtrum etc all the weird settings are right? :blush:


#11

TrueOS can it install some Linux programs? Example Discord or Second Life? Or possible to emulate them to work with something similar to WINE?


#12

FreeBSD can run some Linux programs with Linux Binary Compatibility enabled. I’m not sure if the software you specifically want has been ported or not, but it is easy to see on FreshPorts.org


#13

In trueOS is this easy to enable?


#14

FreeBSD isn’t a good idea. Anything based on it isn’t either. You want steam to be supported. FreeBSD does not do that natively.

Sorry @atcsret but it just doesn’t fit the bill.


#15

Well it does not need to run ALL games just the few I normally ran in Linux which was mostly Day of Infamy, CS:GO and Metro Redux games, if more games most be ditched it may be a option as long as it can run Second life decently enough. :S


#16

The point is that in contrast to linux there is no native steam client on BSD. So just to run that you are already running on wine. That can not be a flawless experience down the road and especially since proton is now a thing… There’s gonna be problems is what I am saying. :wink:


#17

Be certain to check the MD5 or whatever hash on the distro you download. I have had a couple that had varying degrees of issues because the download was messed up.


#18

@Nena360 so your question is to find an alternate OS correct?

My first question is why?

And my second question is to please post screenshots of the error text you see so we can diagnose what might be happening.


#19

That is the issue, there is no error code it just has USB failure and that failure moves over to Windows until a CMOS reset is done. :frowning:


#20

Did you try updating the BIOS?