Return to Level1Techs.com

Dell laptop charger not charging battery

I have a Dell ‘gaming’ laptop, the Inspiron 7567. It’s about 2 years old now, and while the laptop works fine, I’ve been having an issue with the charger (and a backup charger left over from a Precision M6600.) Both chargers will keep the laptop running when plugged in, but refuse to charge the battery in Windows. What’s interesting about this, is that both chargers will top off the battery in Ubuntu.

Researching this a little further, it appears that Dell actually embeds a chip in the PSU that tells the laptop and Windows what the wattage of the PSU is. If it doesn’t recognize the adapter, or the adapter doesn’t provide enough power, the system can throttle or just not draw power from the adapter.

However, a pretty common occurrence is that the PSU works perfectly fine, but the chip malfunctions or loses connection to the laptop. Both of my chargers seem to work fine in Linux (no magic smoke has come out yet), so it possible to convince Windows to also ignore the absence of this chip and just charge the laptop?

UPDATE: Actually, Ubuntu isn’t charging the battery…it just says it is. Sigh. It’s looking like I’m going to have to fork over $75 to Dell for a frickin’ power brick.

I recently opened the BIOS on my Dell laptop and saw that they had an option that seemed to disable the check for an official charger. I had initially made a car charger by using an aftermarket charger of appropriate voltage and amperage and tapped into the DC side of the power line (AC unplugged from the brick), which in turn back fed that circuit it checks for which has worked fine for years now.

Unfortunately I don’t have the laptop with me to check if it actually charges without the brick in the equation after toggling the BIOS option, but it’s worth looking to see if it works for you.

Hey can you link more information about that chip? i have never encounter such issue with a charger not working on Dell laptops, i personally own a 7470 and have worked on 2 different enterprise using Dells with no records about it.

usually the charger either works or just doesnt provide any power what so ever.

I will check right now on my laptop if that option its still available.

Do you remember when you found that specific setting inside the BIOS?, i couldnt find anything under Maintenance, Performance or Power Management, my Bios Ver is 1.17.5 Dell Latitude 7470.

It was a few weeks ago on an 11" Inspiron 3000 series with an Intel Atom N3700. I had only looked at BIOS when I first got it a few years ago and I had been running an Ubuntu 16.04 based distro ever since, so I had been thinking about changing the drive out which led me to look for some reason. I don’t update BIOS unless I have a good reason, so the BIOS is original.

This is an old article, but still seems relevant.
http://www.laptop-junction.com/toast/content/inside-dell-ac-power-adapter-mystery-revealed

1 Like

I also have that option in the BIOS. However, it just suppresses the warning. Neither of the two chargers (official Dell chargers, 220w and 130w) I tried would charge the battery.

If the sources I’m reading are correct, it could also be a corresponding chip on the motherboard, in which case I’m really screwed…

So I plugged the AC adapter into another Dell laptop, which had no problem recognizing it as a 130 watt PSU. Which means that my other Dell laptop is toast. The power chip on the motherboard can’t recognize or charge from any power supply. Crap.

I’ve had much better luck with workstation laptops. I guess my next gaming laptop will be a used Precision…

I have the same issue on the 3yo xps of my mother (with a 2 month battery).
i didn’t try linux, but leaving the laptop on the bios won’t charge eather.

i think i have the same issue then… but question, if you unplug you power-supply, does the laptop shutoff ? mine does while windows return 43% batteries :’(

Many Razer Blade 14 2014 2015 2016 models had similiar problems, all caused by a dead or rather “zombie” TI BQ25A.

No clue what chip Dell decided to use on those, but replacing it shouldn’t be any Problem.

@vlycop I haven’t let it run down < 50% yet. I don’t think that’ll b e a problem, but I’d rather keep what battery juice I have in reserve just in case of emergency.

@RageBone Were those Razers affected by a chip on the PSU or the motherboard? It looks like my problem is either the DC power jack, or the motherboard itself. If I’m unlucky and it’s the motherboard, I’ll probably just get a new laptop. Motherboards for this laptop run ~$400 on eBay.

Is anyone else laughing as hard as I am at laptop charger DRM?

The Chip is on the Motherboard.

Moth Razer laptops stop charging an won’t even run of off the charger, draining the battery and then staying dead.

So i wouldn’t let it run out of charge under any circumstances

I’m not laughing, I’m crying…:sob:

If you are willing to diy it, the chargechip should cost less then 5$ and equipment to solder it, should total less then 100$.
And you get to keep that for other hobby adventures.

If not, Maybe you will find someone who does repairs regularly and might even know your particular machine.

I’d do it, but i’m located in Germany, so that won’t be good i guess.