Return to Level1Techs.com

Decided to try Intel z590, and facing Driver issues in Win 10 x64. (╯°□°)╯︵ ┻━┻

Cannot mange CSM as all the options are greyed out.

I’ve tried with secure boot - set to windows or Other OS

Using integrated graphics for now. I plan to add a gpu once I get it into a case.

Asus z590 Strix gaming-E wifi

Thanks. Please see my previous post.

I’ve now loaded optimized defaults but cannot get the previously working SSD to boot. There’s no way I can rely on such a system as a workstation.

Hmm.

Do you have a RAID setup? What’s the GPU?

Drivers can be found here if you don’t know:

You’ll also need the latest windows build since Z590 is a very recent platform.
https://www.microsoft.com/software-download/windows10

1 Like

No RAID just a single SSS attached. No GPU installed. Used integrated graphics.

I’m doing a barebones test with the system fitted on a cardboard box. Think of this as a smoke test.

Now that could be a factor!! But how come I’m able to install from an older build? I even ran the windows updater and it says nothing more to update.

It only stops booting if I either add another drive or remove a drive present since boot

Well, the drive you are attaching must be faulty. Try testing it on different computer with Crystal Disk Info.

In can confirm the drives are fine. It’s just that the Asus UEFI looses track of its MBR partition etc. I’ve experienced this same issue before on the Zenith extreme boards.

The trick I used back then when I ran XenServer was to rerun the installer to repair the boot partitions.

I’ll try the Win10 ISO to try and upgrade. Will report soon. Thanks mate.

Well, you shouldn’t use MBR anyway. Go with GPT. How are you shutting the computer down? Doing a reset could trigger such a behavior (holding the power key, switching off the PSU).
What are drive models you have?

Shutdown like normal, click Power off in Windows. Not a hard/forced shutdown. It boots fine after hard/forced shutdown (until a drive is added/removed).

Samsung 850 Pro SSDs 512GB & 256GB

How do you mean? the windows installer choses this automatically right?

Running repair using the new iso you shared works wonders in fixing boot up. Thanks.

Now to return to solve my remaining driver issues

To specify the type of GUIID for the Windows Bootable USB, you can use Rufus. The Windows Media Installation Tool looks at what you currently have on the machine and sets it accordingly, probably. Since you can boot with CSM disabled, it means that you already have a GPT partition table on the boot disk. You can convert the other one with Rufus, or AOMEI Partition Assistant easily.

https://www.diskpart.com/?from=en.nav

Oh, I wasn’t referring to the USB. The issue was with the SSD. OK here’s the setup.

  1. Bootable USB is used to install Win 10 Pro onto SSD
  2. This worked fine until I add/remove any further connected SSDs.
  3. Now, the primary SSD no longer boots, or at least the Asus UEFI isn’t able to boot with it.

The Win10 installer will configure the partition on the target SSD accordingly (I haven’t used gparted or some such to see whether it is a GPT partition or not…).

In any case, the Win 10 recovery USB (made via the ISO link you provided), helped a lot as this allowed me to run a recovery step to “repair” the host OS.

At full load, I’m seeing over 200W off the i7-11700K, this is crazy given it is a 125W TDP part. Wow!

1 Like

Depending on if the installation media uses MBR/GPT specifically for Windows, that’s how it configures the drive it is being installed to.

1 Like

The final fix to all my issues was upgrading the BIOS and Win 10 to 20H2. I didn’t have to install any further drivers, everything was automatically resolved.

Thanks for your help @eray appreciatd.

1 Like

TIL from starting about this the wrong way.

  1. Don’t use an old Win 10 ISO on a newer platform.
  2. Start by installing the latest BIOS ensuring current UEFI is set to optimised defaults.
  3. Get your RAM XMP profile setup to ensure stable operation, i.e. at least it should not lockup POSTs. Bump DDR4 voltage to a max of 1.39-1.4v (also suggested by Corsair).
  4. If you’re using an older Win 10 USB, make sure to update your .NET installs, at least v4.6.2 i needed.
  5. Try and install basic MEI/Chipset drivers from Intel.
  6. Update windows fully and install latest update.
  7. Then look to patch any missing drivers.

When things go wrong, use Win 10 ISO on a USB to repair OS on boot drive.

1 Like