Deactivate Intel RST / Optane

Hey guys,

I’m facing a problem where my BIOS doesn’t allow disabling Intel RST/Optane. It remaps my NVMe to use it with the Intel RST driver. I found a kernel patch but am unable to patch it as it’s too old for the 4.19 or 5.6 ones. It always get rejected and I am not a developer. For some reason there is no option to disable RST in the BIOS of my Dell Inspiron 7490 even though it clearly states that Intel RST RAID Mode is turned on. I can only deactivate the SATA Controller completely, which doesn’t help.

For me flashing the BIOS with a programmer is an option if nothing else works. But wouldn’t it be possible to set it via efi-vars like it can be done with dvmt prealloc? Kinda like that:…etting-dvmt-in-insydeh20-bios-laptops.165104/

I attached my extracted IFR file and a BIOS dump. All relevant options are turned off by default if I see this correctly but it definitely is enabled. I tried resetting the BIOS as well.
I hope somebody is able to help me!

Setup IFR.txt (1.4 MB) (5.1 MB)

Is this to install Linux, or simply trying to correct something that shouldn;t actually be causing a problem in Windows?

Yes I want to install Linux!

Okay, the reason I ask, is because of the text of your first post.

A simple search for “disable RST Dell Inspiron 7490” led here, which led here on the last page and it seemed that endlessOS might be the way.

It seemed a dev from Endless tried to upstream a fix for the kernel to work with RST switched off, but the patch was rejected.
The post implied the Endless dev maintains their own separate branch of the kernel, which Might work

But Again, the wording of your OP suggests you already did a search, and already found this info.

Did you try running EndlessOS?

Wow yeah I did a lot of searching and knew that an endless dev made a patch that was rejected, but I didn’t find that. Thank you!
Will try that out, though I really would like to disable it as well, because I really don’t want to build my own kernel all the time.

Nice it works, I tried booting endless with Ventoy but it failed and dropped me into an emergency shell from which I was able to see my nvme with it’s partitions, wow, that’s awesome. I don’t particularly like those “untested” patches but it’s soo much better than running Windows.

1 Like

Fantastic, and great to hear you got it!

1 Like

Still, does anyone have an idea turn RST off in the BIOS? It’s a pain to port those patches to fedora…

I built a custom kernel for fedora now. Anyone curious can try it out on a Inspiron 7490 without an Nvidia dGPU. I disabled AMDGPU, Nouveau and support for switchable graphics.
You can download from my nextcloud:

You should install Fedora (and the rpms with rpm -ivh kernel*.rpm either in a chroot or normal boot) on another computer to an external USB first, then boot endless OS and then create partions á la Arch (~500MB EFI, 500MB Boot, Rest for Root, the EFI has to be formated with vfat -F32 and the other 2 can be ext4), then mount all of your USB’s partitions to /mnt/a and your SSD’s to /mnt/b. With that out of the way just copy the filesystem with cp -av /mnt/{a/*,b/} across. Done you can now boot Fedora on your NVMe.

I might do a better tutorial at some point. Another way would be to insert the ssd into another computer and do the install over there.

1 Like

Nice, that’s a pretty awesome summary, and some pretty good linux skills… Hats off to you dude!

1 Like


It’s not my first time doing funky stuff on Linux :stuck_out_tongue:
I started with Hackintoshing (Ozmosis, Clover and of course Chameleon) which lead to me tinkering around a lot to say the least.

But I’m far from being a pro. There’s still a lot of stuff for me to learn… Using Arch for example helps a lot. When installing that distro, it teaches you so much about how Linux and operating systems work and boot.

I’m a newb, but find running at problems is a nice way to learn, especially if it is someone else’s problem, or if someone else already found a solution…

1 Like

Totally agree! When I used to run hackintoshes I ran into god knows how many problems and with every step/problem I learned more and more. Especially with running my own Ozmosis as it has to be inserted into the BIOS which is a pain and also lot’s of fun when it works in the end!

1 Like

This topic was automatically closed 273 days after the last reply. New replies are no longer allowed.