Return to Level1Techs.com

Ddrescue

So question for you all. I’m an Ubuntu noob. Just starting to play with it.

I have an old USB drive that is dying. When I plug it in it just sits there Loading… in W10 I can see all the files just errors when I copy them.

When I run lsblk it brings up the drive as dev/sdb but when I run fdisk -l the search just hangs up while trying to read from the drive. In order to break it out of the cycle I have to remove the USB. In the same way when I try to ddresue the drive terminal just hangs.

Is this normal? Should I just wait? or should I try a different plan of attack?

Sorry I didn’t get this earlier, but have you tried to use Photorec to recover the files? from what you are describing, it looks like the partition table is corrupted. If so, it will be hard to recover file names fro your files. but you wcan recover the files. There are other tools for getting the data and some to repair the partition table but…in the meantime, try to use photorec and recover the files.

should be able to get the package of testdisk/photorec

From the documentation:

  1. TestDisk can

    Fix partition table, recover deleted partition
    Recover FAT32 boot sector from its backup
    Rebuild FAT12/FAT16/FAT32 boot sector
    Fix FAT tables
    Rebuild NTFS boot sector
    Recover NTFS boot sector from its backup
    Fix MFT using MFT mirror
    Locate ext2/ext3/ext4 Backup SuperBlock
    Undelete files from FAT, exFAT, NTFS and ext2 filesystem
    Copy files from deleted FAT, exFAT, NTFS and ext2/ext3/ext4 partitions.

  2. PhotoRec ignores the file system; this way it works even if the file system is severely damaged.
    It can recover lost files from at least

    FAT
    NTFS
    exFAT
    ext2/ext3/ext4 filesystem
    HFS+

It’s honestly one of the best tools for recovery I’ve used

If the drive hangs like that, it’s dead.

ddrescue is hanging and not actually running. That drive is hooped.

1 Like

Yeah. If dd cannot do anything with it, then there is not much hope. If you can open GParted and see the disk, you may be able to use the one touch partition table recovery option.

If you do have time to wait, give it an hour and see what happens. You could also just try dd and see if it will create a file.

dd if=/dev/sdb of=<file>.img bs=1024 status=progress