DDR5 having memory failures on rog strix 670e w/ AMD 7950x

Hi folks,

I built a new server (PC Builder - AMD Ryzen 9 7950X, Fractal Design Meshify 2 ATX Mid Tower - PCPartPicker) and I’m having MAJOR problems getting the DDR5 to work.


  • RAM shows thousands of memtest failures
  • System will not boot if I set ram speeds to anything over 4800, even though it should support 5600 natively and 6000 is the sweet spot for an AMD 7950x

Corsair support is asking for memtest results, but hasn’t provided any actionable advice yet.

Memtest failures: Corsair DDR5 Vengeance RGB - epic memory fails - Album on Imgur

What is the best way to debug this issue? I have 4 identical builds, 16 sticks total of RAM. All of it is showing up as bad. I’m guessing it’s not likely that corsair QA messed up this hard, so I’m hoping it’s just a configuration issue.

I’ve never had such major issues with RAM, so any and all advice is very much appreciated. I am still within my 2 week window with microcenter, so I’m open to swapping all the RAM out if it will help.

*With 2 sticks, you have 4

This is a problem with ddr5 in general, most ddr5 platforms REALLY don’t like 4 stick configurations

1 Like

Got it. I need 128gb for these machines to work well, and would prefer to fill all slots.

I’ll point out that the last two tests done were with only two sticks (slots 1 and 2), and I’m seeing the same errors.

What would you recommend?

You have 2 kits with different speeds in your list, are you mixing in the same system?

No, I messed up the part list. All 8 kits are identical

These 4 sticks are my current set. Two of them are in the machine.

Try testing each stick individually you might just have a bad stick in each kit

1 Like

I’ve tested all 4. They all error out on memtest #9. Tried doing one stick at a time in each DIMM slot as well.

Damn, okay, sounds like you need to take the whole PC to microcenter and they can probably sort things out
Whether it’s the ram, the motherboard or CPU, something is not right

If the CPU can’t hit rated ram speeds I’d say that’s reason enough to get a replacement

Got it. I’ll let the boys take a look. I’m pretty sure I got the builds done okay. System was able to boot both into windows10 and arch linux, but within a day both OS filesystems got completely trashed given the RAM was so unreliable.

Thank you for helping me confirm that I’m not an idiot at least, and that this is indeed a major issue.

Before you take all that hassle, take CPU out, look at pins on board, if it’s fine reseat it, sometimes reseating the CPU is all it takes


Will do, thank you!

One more question while I have your attention - is it possible to run 4 sticks, albeit at reduced speed? I’ll accept 4400 or even 3600. I’m running a kubernetes cluster so I need a lot of RAM, but it doesn’t have to be epicaly OC’d.

Yeah it should

It would be interesting if you could run the imc at a lower ratio because the speed is lower

For example it runs at 2000mhz for ddr 6000
So 3600 would be 1800mhz for 1/2 instead of 1/3
Maybe even get away with 2200mhz for 4400mhz but that’s probably not what you want for an ultra stable system

This is giving me some ideas to test out

1 Like

Reseated CPU, pins look OK. Attaching pics for a second opinion.

Re: 1800mhz. Is this the FLC that’s supposed to be half, or what settings is “imc” in the BIOS?

I also found Corsair Vengeance RGB DDR5-6000 C36 Review: Performance and RGB Aesthetics | Tom's Hardware, where they mentioned bumping the voltage to 1.4 seems to have helped. I tried their 36-36-36-76 timings, but the system wouldn’t POST if I set those values.

1 Like

There’s a new ratio for ram, fabric and imc for am5
I can’t remember it exactly off the top of my head

Since ddr5 is so fast you can really run everything at 1/2
It was like 3:2:2 or 2:3:3 again can’t remember

These are the options available to me - could I impose on you a bit more and ask which ones are fabric/imc/etc?

Fclk is the fabric clock, but I probably wouldn’t mess with it much as auto should be fine

What are the settings when you enable expo or xmp

asus dont even have the manuals up on their sites it seems like, but with 4x32gb sticks and all 4 systems failing i would first test at 4800mhz and see if thats stable. i assume it cant do 4x32 at 5600mhz.

edit: make that 4000mhz to start
from msi spec sheet i found this:
• 1DPC 1R Max speed up to 6666+ MHz
• 1DPC 2R Max speed up to 6000+ MHz
• 2DPC 1R Max speed up to 6400+ MHz
• 2DPC 2R Max speed up to 4000+ MHz

1 Like

From the memtest photos, bits 33 and 55 of the second 64-bit word in each 128-bit block are flipped (all the addresses end with 8).

If that is the same for all DIMMs, regardless of the slot, then I would check the CPU/socket - it sounds consistent with a dodgy CPU pad with dual-channel interleave.

From the AM5 pad descriptions it sounds like MAA/MAB/MBA/MBB{1,23} - but I don’t have a diagram to find the location.


( cat <<EOF
3bfb567bd4e5488e 3bfb5679d4e5488e
57c23f1ca1d94355 57423f1ca1d94355
68a6c8e946847af8 68a6c8eb46847af8
c7490d22277673b6 c7490d20277673b6
a47f3335e4228da8 a47f3337e4228da8
a47f3335e4228da8 a47f3337e4228da8
73a6f8d9ac30c918 73a6f8dbac30c918
88d8e4cf1054b943 88d8e4cd1054b943
069f96d848d443a9 069f96da48d443a9
6b36593fa9377ddf 6b36593da9377ddf
ca08fab70c79a872 ca08fab50c79a872
cc34ed5fdefacf13 cc34ed5ddefacf13
) | perl -lne '@n=split(/\s+/,$_);$x=hex($n[0]);$y=hex($n[1]);$c=sprintf("%064b",$x^$y);$c=~s/0/-/g;print($c);'

        55                    33
        v                     v

of course, if it is marginal, then just playing with the volts and frequency may fix it :slight_smile:


Thank you!

I sadly ended up returning ALL of the hardware and building a nice and stable DDR4 build (12900, Corsair Dominator 4x32gb 3200MT/s).

I’d love to tinker with this, but as it was for a work k8s cluster I needed stability quickly so that we could get back to work.

What’s curious is the tests I posted were identical on all 4 machines that I had (identical builds). I’m wondering if maybe Asus messed up the socket somehow. That would be a HELL of a story…

1 Like