DD-WRT has ruined my router

i have a wrt54g v8.2 and i installed the vxworkskiller thing from ddwrt and then when i typed in to get back into the router it didnt connect. i have been battling this for hours now and i need a fix. also when i tried to just install the mini generic ddwrt i had to revert to original because it didnt work, so then my internet connection was crawling slow. any ideas on how to get it to work?

ps i have no default gateway in ipconfig.

This is why you should never mess with your router.

Router = Internet = SRS BSNS

thanks you guys have been helpful. thanks to your awesome posts i can now fix my router.

Qain would be the one to help you. He'll see this and probably have an answer.

This is like saying you should never OC any of your equipment.


I had the exact same problem... well kinda around about 2 months ago.

I purchased 2 WRT54GL's for work and installed the standard verison of the DD-WRT firmware on my router not knowing i had to install the mini build first. This resulted in my router being useless and not even giving me a default gateway in ipconfig. I thought i was screwed after a while. However if you go into the properties of your network adapter and manually set the default gateway to and give yourself an IP that the router supports like or something then there is some hope. http://www.dd-wrt.com/wiki/index.php/Recover_from_a_Bad_Flash go there and look at the "Recovering with TFTP" don't worry what it says when it tells you its only if you want to revert back to old firmware or you don't have the blinking light blah blah blah just follow through with it and download the tool named DrayTek Router Tools. This program will send a chosen firmware file to the router, since your router will look for a firmware file upon boot up . As soon as you can ping your router upon boot be sure to push through the new firmware file straight away as you have limited time to do this. After this is done your router should be back to its old self. Hope I have offered the right solution to your problem, I know it worked for me anyway. Good luck

The VXWorks killer app is stage one in upgrading your router to DD-WRT.


Stage two is using the command line and the tftp client to push this mini-generic firmware onto the router while it is booting.
Remember to read all instructions

This is a basic runover of how to get a WRT54G v8 upgraded to DD-WRT.

1) Log into the WRT54Gv8.
2) Under the Administration tab, RESET TO FACTORY DEFAULTS. (it will reset the IP address to
3) Log back into the router and go back to the Administration tab [].
4) Upgrade the Firmware via the Linksys GUI (vxworkskillerGSv7-v3.bin)
5) Update will be successful.

This is where you need to start.

6) Manually configure your Network Card (on your PC) to a manual IP something like
7) Hold down the RESET button on router for 30 seconds.
8 ) Wait about 30 more seconds, then unplug router.
9) Open command prompt, and use TFTP command:

tftp -i put dd-wrt.v24_micro_wrt54gv8.bin

10) HOLD DOWN reset button, then plug-in router. Then release reset button after 5 seconds.
12) You will see the activity light on your network indicator "go crazy".
[[If #12 doesn't happen AND you get TFTP TIMED OUT; Repeat steps 9-12]
13) Wait until the TFTP acknowledges success.
14) Log into DD-WRT Router!!!!


any admin needs to close this thread.

SImilar thing happened to me with my ver 6 WRT5GS where i had to use vxworks prep to upload, then there was some fucked up situation with it not showing the right screen on the browser so i had to use internet explorer (i honestly have no idea what the fuck happened) then it gave me a screen to upload vxworks killer, then i just had NO IDEA what to do. I didnt know the cmd command Qain gave you either so i had to download some tftp client and even then it wouldn't upload the micro_generic fw. So i had to change some settings for my ipvp4 thingy... I dont know shit about internetsing and it was the first time i'd flashed a router...............................