DaVinci Resolve on Linux doesn't properly fit the screen

Hello there,
I’ve been having this issue, where the Resolve window won’t properly fit the screen on Ubuntu MATE 18.04, as shown in the screenshot below.

This is really bothering me since I can’t access some of the functions in the side menus and can’t switch between Video Editing/Color Grading/Audio Editing with the bar below.

It’s really strange, because it worked fine when I first installed it. I’ve tried switching from Marco to Compiz, maximizing through keyboard shortcuts, to no avail. Everything else is working fine.

Any tips would be appreciated.
Thanks.

Minimum screen resolution, to my knowledge is 1920x1080.

I’ve just checked, and it’s not cooperating with anything under 1080p on my system. (Fedora KDE)

Have you tried resetting your user settings?

Just tried that, no results.

Although I found out I can use Shift+4 through Shift+8 to cycle between the edit, fusion, color, fairlight and deliver pages. I’ll just do that in the meantime until I can get a better monitor (or until they add window borders on the Linux version), since I’m only learning how to use it.

Thanks!

1 Like

That works. I’ve had bad experiences with it on Windows at low resolution as well.


Weirdly, this just happened, but then after reopening it, it’s not fitting properly again.

But, after trying to full screen (that isn’t working but I don’t care that much), and then going back, this happened.


It is not filling the entire screen, but I can at least see everything. I found that I can force it to do this by trying to fullscreen at the color grading page, so Shift+6 then Shift+F. It’s not perfect but hey, it beats missing some of the sliders/effects.

So I guess we can call this one solved.

What I do is go to color page, click on workspace, then reset ui layout. From there going back to edit page will have everything display onscreen. This is on a 1366x768 resolution.

You can try:

env QT_DEVICE_PIXEL_RATIO=2 /opt/resolve/bin/resolve

However it does not support fractions so its either 1 or 2. Mine is fine however some of the Icon and text is pixelated for some reason but otherwise it works. Application is in desperate need of integrated UI options like scaling and theming…

Thread closed as it was outside the guidelines for thread revival. Please PM me or another moderator if you feel the thread was closed in error. See the FAQ for more information.

Feel free to create a new thread if you wish to continue this thread’s conversation.