Data Recovery Options Advice

I had a recent power event that took out an older ARCHIVE HDD, it was made in August of 2015 so I got some good use out of it.

Not really critical data but I think that either the mechanics have died or the logic control board.

Windows 10 Disk Management wants to init the drive but it always produces an I/O error message.

I do hear and feel the HDD spinning up, no knocking or anything else can be heard but none of the tools I’ve tried will find/read any data nor detect any partitions.

Since I’ve migrated over to using Seagate EXOS HDD’s now, things have been running much more smoothly but this was the last of the older HDD’s I had been using and as I want to do I procrastinated in getting the data swapped onto a new HDD thinking I had plenty of time, haha :wink:

Of course I could spend tons to go through a data recovery service but none of this is mission critical and just my own personal data which I can download once more.

I have tried recovering data from previous Seagate ARCHIVE HDD’s in the past with similar issues and had no success so I don’t suspect anything different with this one.

I think I kept the previous logic boards from the older HDD’s so I will see if any of these will work but I suspect the issue is the logic boards failing due to the power event.

Of course nothing is showing up as being burnt nor any kind os scorch/burn marks on the board that I can see.

If anybody has any tricks/tips, no matter how weird they seem, then please let me know, thanks :slight_smile:

The point seems to be exactly the fact it’s DIY personal education “bag of tricks” learning.

Indeed it is, just wondering if anybody maybe has had some luck in getting say a Live *nix distro working on what seemed to be an unrecoverable partition/hdd and which they were using.

“init” meaning “Initialize the Disk”? If Disk Manager is wanted to initialize the disk it means Windows no longer recognizes the partition style on the drive. This can either be due to software corruption or a hardware failure. But likely a hardware failure if you’re getting I/O error messages while attempting to initialize the disk (don’t keep trying this). I would suggest booting a linux live CD (Ubuntu, Mint, Fedora, etc.) and see if the filesystem is accessible. If the partition isn’t accessible but the raw drive size is correct, you might be able to use a live distros that has file recovery tools such as Kali or SystemRescue to attempt recovery.

For the most part, board swaps only work with the same model and firmware version. It’s worth a try but I wouldn’t hold my breath.

Long ago they used to work fine so long as the drive was the same series not necessarily same capacity… it’s relatively simple to do - definitely worth a try.

You can’t just swap the logic boards, there’s a specific chip that needs to be brought over from the old board. I’m pretty sure there was an old LTT vid where he does this, but I’m having trouble finding the specific one because he has more than a few about data recovery.

Edit: It’s the beginning of this video

1 Like

This won’t work for any modern disk drive, because -

- yep, there’s an EEPROM that stores the sector map, calibration, and a lot of other information specific to one set of platters and data. And a lot of modern controllers have this built as a nonvolatile flash section on the same die as the controller itself.

One other option - have you downloaded and ran SeaTools yet? It’s a bootable diagnostic program available from Seagate that might at least give you a little information on what’s going on, as long as the SATA interface itself is still operable.


Thanks for all the advice, I will see if I make any head way :slight_smile:

In order of desperation:

  1. Use GRC SpinRite to repair damaged sectors
  2. Use USB SATA adapter to connect drive, try spinning up the drive in various orientations
  3. Use Recuva or similar program to recover data from corrupted partition
  4. Put HDD in antistatic bag, chuck in the freezer overnight. Repeat steps 2 and 3.
  5. Admit defeat OR pay for data recovery

#4.2 hit it ( no really ) This won’t apply to his case but your #4 & my #4.2 are “stuck arm” fixes.

Kinda funny how paying for data recovery keeps being mentioned. It’s like no one actually read the op post :wink:

1 Like

And some followup information on this thread:

  1. I had not finished recycling some of my older HDD’s, found another 8TB Seagate ARCHIVE device and swapped over the logic board.

Now the device shows up as uninitialized under Disk Management, I’m running the trial version of EASEUS Recovery Tool, I think it used to be Recuva.

It failed/halted about 13 % into the scan of the drive so not sure if this is a trial version limitation or the HDD dropped offline, I think the latter as I could not longer see it under Disk Management.

Removed the HDD and waited a few minutes and then installed it again and trying once more to see if it also fails or completes.

Heh I know this is more for learning and experimentation…maybe even fun if you’re a sicko :wink: but it’s kinda tense “watching” from the side lines. Like an old War Time radio broadcast where they might announce the enemy has come ashore any moment now!

1 Like

If ONLY I could replicate the crackling radio sound too with an old time MIC setup :stuck_out_tongue:

Another update, so far it is scanned about 35 % and climbing.

Since my Terramaster USB DAS devices have individual slot/bay indicator lights, I can see it still active and scanning.

When I switched over to the app it showed the approximate percentage scanned.

I also found another 8TB Seagate HDD, but it was a different model and has a different logic board so no luck there :frowning:

Replicating that old sound is pretty easy, EQ is all you really need. However depending on various other fun things you want to emulate you may need a ring modulator, compressor and a noise generator…oh and some sheet metal for thunder. :wink: The thing about 40’sish radio is the crackle most remember are because we heard it after it was recorded to a medium with that crackle but during the real deal most the artifacts were things like lightning or poor signal (cue the ring mod). Lots of killer ribbon mic’s back in the day thwarted by bad pre-amps or just dirty power. :wink:

Well hopefully it completes. Normally in this situation all you really want is to get the damn thing read only long enough to exfil the data even if some of it is gibbed. I know for me every drive death I’ve ever had was due to the r/w arm so normally freezing and slapping the p1zz out of it was what got things back up. Kinda why I have so much redundancy these days.

Staying on topic of bag-o-tricks though lots of guys suggested various software. In my experience no one piece was a magic bullet. The trick was to have the Pokemon…I mean Them All. You could some times get one to get a drive fixed in a small way, then another piece of software would be able to take that a bit further. Kinda flip flopping between trying them for their differing approaches often times you could slowly cobble things together and get a drive back up so long as it wasn’t a physical failure. r/w arm issue, freeze’Nslap! :wink:

ddrescue CLI is your friend here. I’ve done this a dozen or so times (I offer free assistance for a friend’s church). Normally I get drives of loved ones who passed years back. So many people still have IDE drives in basement boxes.

Ddrescue to an img, copy that and the map file. Then use various tools on the img copy to exfil data. Ddrescue goes for the easy stuff first, then will read backwards on the trouble spots, but saves that for last. The idea is to get as much as possible while it spins, saving the time consuming parts for the end.

Run photorec to piece files, or use any other of the tool out there. You won’t get names, but photorec does a great job of piecing together all types of files, not just pics. It’s truly a bucket of fun, I love doing it. It’s a great puzzle.

If needed, you could try rebuilding the file system by fixing the gpt, but I rarely have luck at this. Good luck, have patience, and use a UPS.

1 Like

Thanks for the advice on that one, I think I’ve used it a time or two before :slight_smile:

Now at 60 % scanned and counting.

1 Like

Gotta love how slow it is, almost like it’s just being a douche to ramp up the anxiety :wink: photorec is a strange one but super usefull.

Well the first scan finished but it didn’t find anything that could be recovered :frowning:

I’m now trying a different tool to see if similar or the same results occur.


Short wave? Growing up the local radio would get the news twice a day from the BBC from 12,000 miles away and the sound depended on the ionosphere weather. “This is the BBC” is etched in my memory in all its gravelly pops, squeaks, and howls.

Not shortwave but just regular AM from the 1940’s. The early days when storms would mess with it, or a family member walking in the right spot heh. Preamps were dirty like their power :wink: