Crysis 2 won't launch

I bought Crysis 2 and I have only gotten it to launch a few times then it crashes before the movie scene is over. A few times it told me that I had an incompatible graphics card. On a few other occasions an error report window popped up saying Memory allocation error for ######## bytes failed. The window title says cryengine error at the top of it.

I've defragged cleaned and searched for bad sectors on my PC. I went to evga and got the latest drivers for my 2-way SLI set up including the enhanced sli patch for Crysis 2. I tried running it from Gamespy Comrade and from the start menu in the games icon with the same issue. The release day patched installed so I assume it isn't that. Only thing I haven't tried yet is turning off my anti-virus which I will try after posting this. Thank you for any tips you might have.

My specs:


2x GTX 260 c216

Xigmatek 850w sli PSU

Intel q9550

Corsair Domninator 1066 2x4GB ram

Velociraptor 300gb os and games

WD caviar black 1TB media and storage

Window Vista 64 Home Premium.

Window Vista 64 Home Premium.

I wouldn't be surprised if that was the problem

Abstract said:

I wouldn't be surprised if that was the problem

I didn't think to check but do you suppose the EA Download Manager would prevent it from running right it? I'm not sure if the game has DRM on it and I think that EA DM has something to do with DRM. I tried opening EA DM and it said it failed to launch that too. I reinstalled it and I'm gonna try it again. I see the icon in the app tray in the lower left corner after I reinstalled it. Lets cross fingers and hope it works....

Yeah, it could be something like that.

I'm really not sure, after their demo freakin failed to work for me I kinda gave up on the game right there. Looks like they didn't improve much of anything for the final release either.

It was the EA Download Manager. Sorry I didn't get back right away. I've been playing it ever since.