Crosshair v formula z help!

just build my new computer and the audio is not working at all. when i try click on it on the bottom right cornter a window pops up saying "detecting problems" then after that it says "troubleshooting couldn't identify the problem"..... i dont konw what to do, i already downloaded the drivers and i dont know what else to do. HELP!. by the way im running windows 7

have you gone to the asus website and gotten all of the drivers for the board.  for my chrosshair v formula i had to get the sound drivers from asus to get the sound working correctly. if you have already done that then best thing i can say is  try reinstalling the drivers 


Just downloaded it.... didnt work :(

This is pissing me off so bad dudes! was up all night last night trying to fix this stupid problem! This is my first time using a ROG board and I thought it would be a awesome experience, but instead its not.... HELP!!!!!!!!!!!!!!

fixed it! all i needed to do was enable the sound in the BIOS.... smh im an idiot lmfao 

glad you got it fixed :S first place i go is bios so i thought you tried it already but  either way you got it and you can now game on happy.


I have the same problem right now :L How do I enable sound in the BIOS?

Hey not sure if you have resolved your issue but if you have not or any one else finds this thread and needs help. I was using a USB headset for months till my mother wanted to watch some videos and hates headsets and none of my speaker/headphone jacks were working so I had to figure it out below is the fix.

restart to BIOS

Go to Advanced settings

Click the Advanced Tab

Click "On Board Devices"

Click on "SB HD Azalia Configuration"

Click Enable

Save and restart

From there make sure you have the current audio driver

and you are good to go


Hope this helps someone else in the future. 


The topic is over `year old, i guess the problem is solved allready.

I will put a lock on it. Thanks for the tip anyway.

Grtz Angel ☺