Return to Level1Techs.com

Crosshair 7 hero slow to post

Anyone that uses a CH7 board have slow post times? It takes 20-30 seconds to get video. Once I see the bios splash screen it boots to the OS in under 10 seconds.

Searching the web, I see some posts over on rog forums about it but nothing other than wait for bios updates etc.

One person watched the post codes and noticed it cycles through the codes and resets 3 times which seems to be what mine is doing.

This would seem to be a RAM issue. What are you running right now? I have had a few occasions on which my Prime X370 Pro board would reset a few times before the RAM speed stuck (not stable though). My board doesn’t have a separate boot voltage but I believe the C7H should and increasing that may help.

IIRC most boards default to 1.2v for DDR4 and on many kits that’s too low for an OC speed.

Somewhat relevant: https://rog.asus.com/forum/showthread.php?93841-Why-you-should-not-set-the-DRAM-boot-voltage-too-high

As @Steinwerks said, it could be instability.

Most modern motherboards will apply overclocks as they’re turned on, but if they can’t they’ll cycle a few times to try and apply them before reverting to lower speeds.

If your motherboard has multiple profiles you could try booting from a profile with default settings. Theoretically if it boots right off with default settings but is slow with overclocked settings then the overclocks may be what’s causing the hiccup.

G.Skill 3200 FlareX CL14 8g x4 @ 1.35v, I have tried using the default settings the motherboard selects which is 2400 at CL 16 @ 1.2v, I currently have the bios set so D.O.C.P. mode wich allows me to select the correct timings and voltage for the specfications on g.Skill’s website for this ram.

This makes sense I mean it sounds like what it may be trying todo, but I’m just using the defaults. I don’t really know where/how to look at changing this. I’m not in to OC’ing I just like having that option and normally like to get the top tier hardware, as it’s seemed to do me well in the past.

This is my first AMD system, I’ve always done intel/nvidia for as they seem to just work with out much tweaking.

I did attempt call ASUS on this but got a canned response, no reports of this issue etc, it’s your power supply or other componets causing the issue. Let’s try reseting the componets etc, I had pretty much already done that yester day. I built this on the 18th and didn’t like the case I picked so took it back yesterday and got a diffrent case so other than reseting the ram and cpu that’s been done.

The slowness is only from a cold boot too, forgot to mention that. If I reboot it’s like 2-5 seconds before I see the bios screen.

I have run memtest in windows a few times everythign comes back clean run prime95 for 30 min. The system seems to be stable once everything is running. It’s just that inital boot that is taking 20-30 seconds.

Posts from ROG Fourms
https://rog.asus.com/forum/showthread.php?103878-Hero-VII-Ryzen-2700X-very-slow-boot-time

https://rog.asus.com/forum/showthread.php?103152-Crosshair-Hero-VII-slow-Bios-post

When looking at those, most have the same ram as I do so was thinking maybe that’s the key, but one person has Corsair 2666.

When talking to ASUS they “esclated” it to the next tier, so will have to see what they say. I’m hoping it’s just a bios fix or something simple.

Looking at my settings in the bios ther are 4 diffrent pofiles to chose from, and the AI Overclocker Tuner has 4 settings.

Default - Uses stock base clock specified for the processor. (I’ve tried this one, it’s actually the one you start with)
Auto - Sets an optimized base clock determined by the bios (Sounds like what your saying it may be trying todo, I have not used this one at all)
Manual - no explantion needed here :slight_smile:
D.O.C.P Standard - Loads standardized unbiased settings. (the best I can tell this what ASUS is calling XMP for memory timings, because enableing this allows me to set the XMP profile for my ram) - Current using this setting.

This could be normal.

And yes it does take a while to boot. Many people comment on this and the general answer seems to be that it was the same story with C6H until the BIOS matured after about a year.

You could ask on the C7H thread on OCN, but my guess is your system is fine.

From here: https://rog.asus.com/forum/showthread.php?101617-Crosshair-VII-Hero-Essential-Info-Thread#post717127

And in External Digi+ Power Control page set:-

DRAM VBoot Voltage [1.35000]

Make no mistake, 3200MHz DRAM is an overclock outside of JEDEC specifications, so it may take some tweaking to work in many instances, and is never really guaranteed.

The above would be my first step to attempting a faster boot if indeed the system is looping 2-3 times.

Just checked it is set to auto for boot voltage, it won’t let me change it unless I put it in manual mode. I’ll have to read up on that article more before I try setting everything manually, I don’t want to OC the processor just get the ram running at 3200, I suppose the other option would b eto save money and get ram I don’t have to fiddle with :slight_smile:

Hey @GrumpySasquatch!
I have been using the Crosshair VII Hero aswell and realised long boot time in Task Manager is like 25 Seconds. Have you found a fix for it yet?