Return to Level1Techs.com

Crazy gigabyte X570 Master issue

I’ve built my own computers for years and worked with many gigabyte motherboards but I’ve never seen this kind of problem before. Everything works great until i flash the main bios to a newer version. Then it fails to load windows. However the back up bios works just fine, so it clearly not a hardware issue. I can access the main bios and change any settings but It won’t load windows. It states there is no boot drive available. I thought this may have been a defective board as did gigabyte when i put in a ticket for technical support, However i got a replacement board from amazon as i thought the first was broken and now the replacement board is doing the exact same thing. It has to be a software option somewhere, but i can’t for the life of me figure out what it is and have searched everywhere. Does anyone have any ideas? I’ve tried re-flashing the bios, clearing the CMOS, loading optimized defaults ect. but to no avail. The only post code is AA, which apparently stands for reserved whatever that is. Any help would be appreciated.

Thank you.

You did not mention if your boot drive is NVMe or SATA but no worries.
First thing to check is if the system sees the device. The easiest way would be to enter the BIOS and go to easy mode (hit F2 to switch between easy and advanced) Check the SATA, PCIE, and M.2 tabs and confirm your device is listed under whatever is appropriate. Assuming it is then hit F2 to switch to the advanced mode and go to the Boot tab. Check the boot option priorities verify that for option 1, Windows Boot Manager is listed. If not make it so - Save and exit - see if you boot to windows.

If that doesn’t work but all of the above is still true you might check to see if CSM (Secure boot) is enabled and if so set it to disabled (same advanced mode boot tab near the middle). Save and exit - see if it boots.
I am assuming you loaded windows in UEFI mode but if not you could go back into the BIOS and try changing the Storage Boot Option Control setting (Same advancec mode boot tab towards the bottom). I am assuming it is set to UEFI only - the options are UEFI Only, Disabled, Legacy Only. Try changing those one at a time .

Try that for a start - Good luck

Its a 2.5 Sata SSD, and it is listed as found. When i select it, it attempts to boot but does not. I just get a Aorus screen with a never ending circle going around.

Funny enough boot manager is only listed in easy mode but not advanced. Selecting it makes no difference.

I have tried all three of those modes, legacy, disabled and UEFI. I’m going to check the CSM now and will get back to you but i think it’s disabled.

OK - yes you can try changing it to the opposite of what ever its set at.
Also - could try disabling fast boot if it is set to Enabled.

That fact it sees your device is good - its a boot thing - where windows thinks it booting from - and I have seen this happen before even to myself. Doesn’t mean it is easy to sort though - I think I actually gave up and reloaded the last time it happened - but I have also sorted it out in the past too - getting lucky I guess. Not this board but different

I have the x570 Master myself it is a good board

One thing to mention is that during trouble shooting it is easy to confuse things up by making changes - it doesn’t work go in and make another change etc. You might need to set the first things back to where they were before making a new change - if that makes sense.

You could try looking at these settings when its booted to the saved bios - and see what is different and try setting the updated bios to the same settings.

I appreciate your help!

I’ve looked. even took pictures of the working bios and the new bios. Everything seems to be the same. Cleared the CMOS multiple times, reset to factory optimized defaults multiple times…Its driving me mad. and this is the second board so there has to be something somewhere.

one other piece of info.

If i don’t go into the BIOS i get the code AE and it states that i need to insert a boot drive. But if i go into the bios and select the boot drive which it sees i get the code AA and a endless black screen with it attempting to load windows. Slight difference but same result lol

Really sounds like a Windows Partition manager/boot loader deal. like the device ID is different in the new bios and such. I am not explaining it well, sorry. One other suggestion - boot into windows from the working BIOS and then disable fast boot in windows while troubleshooting . I cant recall if it takes effect right away like on next restart so might need to reboot twice to make sure. You can google disable fast start in win 10 should get you plenty info.

Hoping one of the “smart windows guys” will chime in.

Real quick - what version bios works and what are you updating to. Second what GPU are you using and is the PCIex16 slot set to use Gen 4? if so set it to Gen 3

The secondary bios is what it shipped with F4. I tried updating the the newest one F10 but i also tried going back to F7, F6, and F5. I’m using a RTX 2080 TI and it is in the first slot. I have PCIe set to auto in both bios but i’ll try switching to gen 3 and see if that makes a difference. Willing to try anything lol.

That’s really bizarre. Maybe do the bios update and use the windows installation media to reinstall the bootloader.

I tried using the windows tool to repair. It can’t repair anything and it wont allow me to install because there is already a copy of windows on that drive lol

No you do the bootrec fix. Its a little more involved. I’m on my phone but I can look it up for you later if you want.