Cpu error on asus z97-a

had an amd rig and swapped out mobo and cpu worked fine never did an overclock was making sure everything was stable for a week or so and then used sleep mode and it came out of sleep mode and didnt come on but had a cpu led error, so i got a new cpu since thats easier to swap then the mobo and flip it on and cpu led error again so flip power on the psu and turn it back on works fine, shut it down turn it on and same led error so turn of at psu and turn on boom turns right on im at a loss i hate to send mobo in dont want to be with out the computer any one have any idea?? i also tried to unplug all the hard drives and see if it would boot bios and same thing led error 

what was the led error?

its just an led on the mobo by the cpu there is no number, this mobo has led by the cpu, ram, pci slots 


I think that LED can be an indicator for the RAM as well Reseat the RAM then try again. it can also indicate an overvoltage problem did you OC it? Try clearing the CMOS using the jumper.

i have not done any overclock and everything in the bios is stock and i have updated the bios from the ezupdater  that asus has and there is an led for the ram if there is a ram error but i had no problem with the ram in the last mobo, not saying it couldnt have gone bad but once the computer is on everything is fine i mean i had it on for a week with no problems played games and everything temps on it dont get over 50c either  

I would start with reseating the RAM and juggling the DIMMS try one then the other then a different slot etc. If that isn't working I would swap the PSU. I worked on a friends z97 a few months back and it had a similar problem. In the end it turned out that the modular connecter for the HDD power was bad. can you believe that a stupid wire the least complicated part of the rig. It was a special kick in the throat because we replaced the PSU but not the wires b/c you know modular PSU easier to not redo the cable management.

i tried swapping the ram around and only using one stick and nothing i will try resetting it worth a shot and i dont have another psu on hand and the one i have is not modular, not saying a cable couldnt be bad just sucks when everything is fine add new mobo and cpu and then this i would like to think its just the mobo just sucks pulling it out and waiting for a new one 

I feel your pain. Good Luck.

reset ram, turn on led error..... took out dimm 2, turn on, led error turn off back on worked fine with single 4gb, shut off put in the other ram stick in the slot for singe dimm, turn on led error, shut it off turn it back on boots fine, shut off put both in turn on, red led error shut off back on and it works...... :/ probably just deal with it untill it dies for good unless some one has any other ideas.... hope that all makes sense