Corsair PSU's keep dying on me! Whelp it's the Motherboard

I've been through 3 corsair power supplies now and they each die within 4-12 months, the first two are the VS350's and I tried to fix the issue by going higher by buying a RM-550 and yet...still no decent PSU for my server running FreeNAS.

My specs are:

  • AsRock C2750D4I
  • 4x8GB Crucial CT102472BD120B.18FED
  • 6x2TB WD Red WD20EFRX
  • Corsair RM-550 80 Plus Gold

When I flip the rocker switch on the PSU and leave it for about 10 seconds and flip is back on, it powers on for about 10-15 seconds then shuts itself down, the weird thing is the motherboard LED's still have power...not sure what's going on here.

I've tested using this method: and the fans work, as of writing it's been about 2 minutes and it's still spinning.

This system is on 24x7 so that may be it, or the storms that passed through must of done something to it, it's been 2 days after that that it finally had this problem. I cannot test no less than 6 HDD's since freenas needs all of them, it needs all 6 to boot into the pool otherwise it cannot access the datesets.

I've tested how you said and it took a while longer to shutdown by itself and then after that it takes 3 seconds to poweroff by itself, then I just plugged in everything but the motherboard and it's still running as of writing....I really hope it's not the ram and motherboard since that's imported and expensive since I live in Australia...

Yes, the PSU runs fine with everything connected (HDD's and fans) but the motherboard (MB, RAM, CPU).

I'll test the ram individually to see if either of them are damaged, if not then I'll test it with a backup vs350 (that was claimed under warranty and it's previous component to the server), if that also fails then I have to figure out how to claim warranty on the motherboard which will be a pain if it's not international :(

I'm currently testing the ram sticks individually right now and yeah the motherboard is plugged in also. After I'll try 2 sticks in dual mode and see if that bugs it out. If not then..idk. The cpu is a SoC if you check my motherboard so there is no need to plug in the cpu power cable.

Alright then, I'm fairly certain it's the AsRock C2750D4I that's failing, I've tested the ram until the 3rd stick when it just shutted down in after 5 seconds, then I tested with no ram and it also shutted down after 5 seconds. Then I plugged in the backup vs350 with the MB and fans connected and the same result. However just by stand-in power on both PSU's I can access the asrock IPMI management page after a while when turned on and it posts logs on OEM timestamps.

So now the only option I have is to see if I can claim under warranty...any other suggestions?

Get a Seasonic. Never had a fail yet lol

XFX if you want a budget seasonic

We've established that it's not the power supply but the ASRock C2750D4I which is the motherboard with the SoC CPU. But cool suggestion.

I wonder if @wendell had this problem since my hardware setup is similar to his.

I've looked in my archives and I purchased this for ~$600AUD and it arrived on the 6th of May 2014, I guess that 1 year warranty is out of the question :(

...on further speculation, if I can access the IPMI via ethernet and I cannot POST on it then maybe the SoC CPU itself has died.

On that note, I've got two alternatives until someone has a better one,

(1) I replace the ASRock C2750D4I from here:


(2) I go the non-energy saving, loud fanned, non-SoC route by buying these: (CPU) | (Motherboard)

Sure I can get a CPU cooler if the stock cooler is too loud...

Sorry if I come across as aggressive, I'm just a little angry and frustrated that my SoC dies like that, taking the Motherboard with it...

Alright, I'm in contact with ASRock to see if I can get it replaced under warranty, I'm going through the process now. Fingers crossed!

Well yeah, if you followed the posts. We were going through a troubleshooting process and apparently it's the SoC CPU.

Yeah 24x7, it only had FreeNAS on it. Must of been something wrong when it was manufactured since CPU's don't die easily when using them, especially in this day and age. It's was in a fractal design node 304 with all three fans on full blast, the room temp doesn't go higher than 27C.

Yes, I've tried my backup PSU as well, with all RAM and HDD's out, the IPMI works but nothing else.

That's what I'm going through now, waiting for ASRock to send me a form to RMA it and go from there.