Continuous Crashing On Ryzen

I need help figuring out why my pc is crashing hope I put the post in the correct category if not admins feel free to move it.

My system specs are as follows

Asus Prime X370-Pro
Ryzen 1700x
Gskill Ripsaw ram 8GB x 4
850 evo m.2 ssd
Adata ssd
Enermax Platinum PSU
I had a 1060 3GB installed thought it might be the problem so swapped it for a Radeon HD 5770

I am having random crashes that leave the image last viewed on the screen while mouse and keyboard no longer work even to switch to tty3 and the only option is to power off the pc. Every crash leaves nothing on any system logs. I have tried switching distros Arch, Manjaro, Ubuntu, Pop os, and many more . Even multiple desktop environments Gnome, Xfce, Mate, i3. I have tried multiple kernels and I see no difference. I have also tried about every motherboard setting I can think of. The only thing I have not tried is windows which I refuse to use due to the privacy concerns.

Any help or advice would be gladly appreciated.

In the event of a hang, could you still ssh into the system? Might give a clue as to what’s causing it at runtime.

Can you tell the exact product name of the memory kit?

Disable C-States - try again
Update UEFI - try again
Set DDR4 to base speed 2133 - try again
Remove two of your four dimms - try again
Leave only one dimm installed - try again

After that look into Ryzen kill script testing.

1 Like

From the Newegg order form, The ram is G.SKILL Ripjaws V Series 16GB (2X8GB 288-Pin SDRAM DDR4 3000 (PC$ 24000)
Model F4-3000C15D-16GVS

I have to wait for it to crash to find out if ssh will still work.

That seems to be Hynix memory and it is not listed in the QVL.
I know I can get two sticks of very similar memory up to 2933MHz CL16.
Four sticks of those are probably a bit much to handle, especially on a first gen.

Try running mprime -t with XMP settings. You might see errors after a while, maybe half an hour.
Oh also, temps?

1 Like

I had the same problem, with the same memory. Apparently, it was due to an unsolved compatibility issue Ryzen has with RCU callbacks. I fixed it by disabling them with the kernel parameter:


With ‘0-11’ referring to the 12 cores of my 1600x. For your 16-core 1700x, it would instead be ‘0-15’.

I added the parameter via syslinux.cfg in Unraid. In Ubuntu / Debian, you should be able to add it via /etc/default/grub by appending to this line like so:


This Hynix Memory as 4 DIMM’s is an absolute pain to deal with for Ryzen.
I’ve experienced the same issue countless times here with people buying cheap corsair Hynix memory.

2 DIMM’s no Problem
4 DIMM’s run slow at 2133Mhz and take insane tweaks to get stable at 2666Mhz or higher.

Also @Chip what BIOS version do you have?

I Disabled C-States
The ram was running at 2133
Cpu temps are 29 C on idle and 58 C when stressed for a while
Removed 2 ram modules will see if that helps
Will have to try adding the line to grub
@catsay Running the latest BIOS install able by the web updater

For got to mention sshing into the system does not work when it crashes

Mine has been running at 2933MHz or better since I grabbed a second kit, so 4x8GB Hynix (Corsair LPX in fact). Running at 3000MHz now, and the latest BIOS update seems to have helped with stability (had crashes in a couple games - DOOM specifically as of late).

But my experience is just one anecdote among many, so of course YMMV.

Do an AIDA64 latency test :wink:

Curious to see what you’re getting with 4 Hynix DIMM’s.

I can probably manage that after I get home this evening. I know tRFC is absurdly large but I just can’t stand messing with subtimings: too impatient.

Welp, trial has expired… :man_shrugging:

This seems to have fixed the problem. I might have to get some different ram. Thanks to everyone for the help.