Computer wont Boot into Bios

Computer turns on but nothing shows up on the monitor. ive tried hitting delete and F2, but that hasnt worked either.


Motherboard: GA-78LMT USB3

Ram: 8gigs of HyperX 1600mhz

Cpu: AMD FX black edition

Gpu: Asus Radeon R9 270X Direct CU II top

HDD: Seagate 1tb 

PSU: EVGA bronze certified 500w

it also makes a strange staticy noise whenever on. 

Should i take it to NCIX? or should i try to conduct self repairs.

Bad motherboard choice for that cpu.... in either case it needs the F3 bios for the cpu to work. (8350/8320/6300/6350)

Otherwise try these things first;

  • check power connections.
  • motherboard standoffs are correct, and extras that may be shorting out the motherboard are removed
  • ram is inserted in the correct slot/s and in far enough.
  • try another gpu in case of the 270 being DOA

That strange noise is most likely the board having a fit trying to supply enough juice to the hungry cpu. Be careful of the area around the cpu socket - it'll be crazy hot.


pardon my incompetence, but what is an f3 bios and how do i acquire it?

and should i just buy a new motherboard?

it ran without the graphics card, any idea why this happended?


The board may not be able to supply enough power to both the cpu plus a pcie lane ~ hence it will boot without the gpu. Try the gpu in another system - if that doesnt work its DOA - so return it.

What model cpu did you get?