Computer not recognizing new m.2

I bought a samsung 960 evo and a m.2 to pcie adapter and i installed it onto my sandy bridge era motherboard. I was expecting maybe some issues with trying to get it to be the boot drive, but i can’t even see it anywhere. What do i need to do to get the computer to see it? Oh, and i’m using win 7 pro 64 bit

new ssd

I am not 100% on this but I dont think sandy supports NVME. Just a quick bit of reading it said started support in skylake.
Anyone able to correct me on that

1 Like

Without a bios update that board is not going to do NVME.

Last I checked, my Has-E system predates Skylake and has an NVMe boot drive.
Not sure if the 4xxx series has support though.

Are you x99?

So does mine, but it required a uefi update to work. Other m.2 drives would work, but not NVMe, until after the update. Chances are, board manufacturers don’t care enough to support it on a SB board, whether they can, or not.

Yup, X99 with 5930K

Looks like thats why. I think sandy is a little too old unless the mode maker realeased a uefi update in the last couple of years. Sorry op new mobo and chip

thanks guys, i might try this

Today on buy first and worry about compatibility later…


lmao, well, i bought an adapter at the same time, so clearly i worried about compatibility from the start. It isn’t very widespread knowledge knowing just how compatible m.2s are with certain motherboards.

It kinda makes sense that it would work with an adapter, but apparently it doesn’t.

I remember running a PCIe SSD on my own Sandy rig (OCZ Revodrive X2 240GB on Z77A-GD65 Gaming and i5-2500), So I know that you CAN get data through PCIe at “greater than SATA” speeds.
BITD those PCIe SSDs had their own drivers and didn’t really adhere to any standard so the manufacturers simply made them work with whatever hardware you were using.
Nowadays though it’s a different story, as you’ve found out.



Not much you can do but install the latest BIOS and play with the settings.

I kept an i5-3570K + Gigabyte Z77 mobo as a spare when I switched to X99. When the X99 was RMA’d due to the early DDR4 cold boot bugs I swapped everything to the Z77 board which included 2 x Samsung 951 NVMe M.2 drives plugged in to 2 x Asus PCI-E adaptors. They simply worked straight out the box and booted into Windows 10 from the 128 GB 951 M.2.

However yesterday I was installing a Samsung 950 EVO M.2 SSD drive into an i7 4790K + Gigabyte Z97 board and it worked fine in the 10 gb/s board M.2 slot (and disabled the SATA 4/5 ports) but would not even show up in the BIOS when plugged into the same Asus PCI-E adaptor I used in the Z77 board. BIOS update did nothing.