Computer Not Booting - solved

So I have this old Asus Sabertooth X79 motherboard. I migrated it to a new case cause I was making a dual boot machine but when I turned it on the UEFI/BIOS gives me an error. It says

“The current BIOS setting do not fully support the boot device.”

“Then it says got to Advanced > Boot > CMS parameters and adjust the Compatibility Support Module settings to enable the boot device”

After clicking ok it brings me into the BIOS settings and it shows all SATA ports being empty so I am unable to boot off of my drives.

I tried resetting my BIOS by removing the CMOS battery and by using a jumper. I have tried all of the SATA ports. This worked before I moved it to a new case so I am not sure why it is doing this.

Let me know if you need any more information and I will keep updated if any of you would want to help.


check your UEFI boot settings.

may need legacy enabled or visa-versa(depending on how you installed your OS

I have tried all of those settings. Currently its set to UEFI and Legacy OPROM.

Currently its just a HDD with Linux.

Did you plug the drive into the same SATA port as before?

From the Specifications of your board:

Intel® X79 chipset :
2 x SATA 6Gb/s port(s), brown
4 x SATA 3Gb/s port(s), black
Support Raid 0, 1, 5, 10
Marvell® PCIe 9128 controller :
2 x SATA 6Gb/s port(s), gray
ASMedia® ASM1061 controller :
1 x Power eSATA 6Gb/s port(s), green
1 x eSATA 6Gb/s port(s), red

You probably want to be connected to a brown port. If you are plugged into the Marvell port, Is it enabled in the BIOS?

I just tried that in the brown. I also tried all the other ports as well.

Can it boot linux live iso or windows installer? Does the mobo show the drive in bios? have you tried different sata cables or a different drive?

I tried different drives with different sata cables and I cant boot into anything. I know it can boot off of a flash drive but not anything through the SATA ports. as far as the BIOS is concerned nothing is connected via SATA.

When you boot of USB does it see the drive or no?

I should have said it see’s the flash drive but I have not tried booting off of it yet. Later tonight or possibly tomorrow I will get a response to that. I will need to get a flash drive ready.

1 Like

I got a OpenSuse boot drive on my flash drive. Still doesn’t seem to see the SATA ports. Might just end up ordering the PCI to SATA card.

What’s the board condition like? Any bad caps, marks, etc?

If the SATA ports do not appear even with alt boot, might be the on board controller- in which case you might want to consider another mobo, unless you’re good at diagnosing that kind of thing.

Changing to pci-e card is putting a band aid on the problem, imo.

I know that, basically I dont just want to replace my motherboard. When I get a new one I want to upgrade of course so I at least want this to last till the end of college, then I will probably just replace the mobo anyway and my CPU and RAM.

I also dont see any physical marks on the motherboard.

I went straight from core 2 duo to Skylake so excuse my ignorance. Is there a SATA compatibility mode or something? I seem to remember some boards having ahci or ide (or raid) modes for SATA stuff. Might be on the wrong track here. I think the device would still show in the bios though.

You’d likely want ahci and csm enabled.

1 Like

Bad news, I inserted the card that is PCI to SATA and still nothing shows up.

Guessing that its either some complicated BIOS problem that some combination of options will fix it or the PCI to SATA card doesn’t come with its own SATA controller and thus if my SATA controller somehow got damaged then the card would do nothing.

You mention having enabled CSM, but nothing about the keys; have they been deleted/reset?

Not really a fan of Asus boards, so minimal experience here, but i do know both X79 and X99 had issues with those and hard drives (including SSDs and NVME M2s). Prior to switching to CSM, one must also sort out the keys generated. I don’t recall how it’s phrased in the BIOS, but it should be in the same page.
You can even find videos of this, was a long time before they sorted it.

Now if you’ve already done this, seeing how you’ve tried all your SATA ports… i’d try a different, brand new, empty drive, of any kind; no boot manager in it. Or externally format the one you currently have and try a boot override if it now sees it.

One thing I tried was setting my HD to IDE mode on a dying MB. It worked for a year after.
Sorry to hear this @shane, Hope this helps

are your sata drives getting power?
regardless of whether the bios is in uefi or lagacy /ide mode
it should still detect the sata drives

check for the mobo shorting against the case someplace.
as you stated this board was working before

the bios needs to be set to auto detect the drives as well.
uefi mode will not let an unauthorized os to boot as it is looking for the key

1 Like

turns out they wernt, I discovered this after buying a new MOBO.

It was an excuse to upgrade to the new Ryzen 7 anyway and ddr4 lol

1 Like