Computer doesn't start, did the motherboard die?


My pc decided to take a crap on me, and it won't start.

The fans spin up, no video output, the optical sound output and the leds on the LAN port doesn't light up on the motherboard, it turn off if i hold down the power button.

Tried with one ram stick, without the gpu,disconnected everything, reset bios setting, remove cmos battery.

The USB ports do provide power.

It happened when i tried to start it, but the USB 3.0 external hdd was plugged in, it tried to boot from it, but it's empty,so i restarted it and then, it happened, the pc won't start up again.

on the side note, i have installed a new cpu cooler a month ago, i don't know it it could have anything to do with it.

The speces:

AMD phenom II 955

Nvidia GTX460

2x2gb ram 

Gigabyte mobo with 870 chipset

650watt 80+ chieftec psu


Did the Motherboard die or the cpu, or both?

Any help is appreciated 

Now I have 2 things that could solve this.
1. Wiggle the ram a little bit inside the slot.
2. Is the CPU fan plugged in? 

The motherboard should show a splash even if the cpu fan isn't plugged in, and there is no ram. My bet is that the mobo is bad.

From my experience I have a old intel board that said absolutely nothing until I realized the CPU fan wasn't plugged in.

Yes, they are plugged in, i tried the ram, one-by-one , both modules.

Do you have a beeper? I assume you can just put a single in-ear headphone onto the pin's using a connector (or tape) if you can find the header.

Yep, do plug in a mobo speaker.

If it beeps you can look up what is wrong,

if it doesnt beep there is something wrong with the mobo -->replace it or try with the old cooler/a reference cooler (the new one might flex or short out the mobo).

I have  a beeper, but no beeps at all.

If you don't want to read my long, boring story my conclusion is make sure your f_panel on your motherboard. Maybe the power button cable is loose.

So I got a new Corsair Spec-01 a couple of days ago so I had to shove my PC from my other case into the new one. After a good few hours, I powered it on to see if it even worked. There was no response. I stayed calm and started trouble shooting. I wiggled around cables and etc. Then I looked at the f_panel on the motherboard. I took the front part of my old case and connected the power button and it powered on. Turns out I had my power button cable in the wrong way.

If the power button wasnt connected the fans wouldnt spin up.

You could try a cmos reset again, how exactly did you do it the first time? Just removing the battery for a few seconds often doesnt work, you have to also use the cmos jumper or wait an unknown amount of time to succesfully clear the cmos (might be 5 minutes, might be 5 days).

Other than that you could take out the mobo, use the minimal amount of components, put on the stock heatsink and try again.