Computer crashing at bios

I build my computer up for like the third time, and it's starting to act super funky. My computer posts, but then freezes at the splash screen. It will occassionally allow you into the UEFI, but freezes up again before you can even think about doing anything. I need help finding and solving the problem. I am using a Asrock 970 extreme 3 with a fx 6300 and an hd 7970 all powered by a xfx 750

I had something like this on my P8Z77-V Pro

 

Turns out it doesnt like my gaming mouse (Func MS-3). It works fine as long as it is in a USB3 instead of USB 2. Not sure if it will help you but worth a mention.

Have you flashed your Bios?

I tried, but could not. It kept freezing up so I was unable to do anything. Might try with a PS/2 keyboard and usb mouse

 

Contact your manufaturer.If the board is defective you may be able to return it an get a repacement.Just tell them.i have not done anything too it.This is as is.An i would like to get a replacement please.Give them your information.They should address your needs.Sometimes you need to contact you seller.If you still have your product number either they can help you or your manufacture will help you.

 

Seller first

Then factory.

Dismantled everything, then rebuilt it...Now it works properly. WTF!!!

Something must not have been seated properly. I was going to suggest reseating the ram first... then going from there. 

if the computer works for now afther you installed windows, please go directly to the Asrocks website, and download and update to the latest bios version. i readed more complainings about Asrock 970 boards, especialy the Extreme 4, some have problems with a laggy UEFI bios... so i just mention this, i unfortunaly forgotten about wich bios version this problem was writen about, but i just mention it. just look if Asrock has a newer bios version on theire website, and flash it to the newest version. its never bad to do that. (if you know what you doing offcourse)

Grtz Angel ☺