Computer crashing as of late (Fedora 26)

CPU: Intel Core i7 5820K
GPU: MSI 8 GB R9 390
Motherboard: ASUS X99-M WS
OS: Fedora 26 (Kernel 4.11, I wonder if it somehow updated)

I seem to be experiencing a rather serious problem with Fedora 26 lately where the OS crashes out of nowhere (The display is off) and cannot get around that, sometimes the GUI is just frozen or it’s blacked out. I even tried reinstalling the OS and that made matters worse as Fedora is crashing within the installation process.

Basically I am stuck with Fedora not working now on my computer. Is there a problem with the kernel version I am running with my computer?

UPDATE 1: I think the installation media may be part of the problem, but I looked at my BIOS code on my motherboard since my motherboard comes with a dual-7 Segment Display that shows the code. The code is at 00 which is almost like my computer is off but not really, 00 is not a normally used code for my computer. Still not certain on what the error is but there is something strange going on with the operating system and computer.

Page 21 of your motherboard manual states that a Q-code of 00 stands for “Not used”.

I am not sure what that means but here is the link to your manual.

Edit: Found an answer.

Usually a 00 code means hardware failure.

To check for failure on your board use some of the diagnostic LED functions outlined in your manual, also in chapter one.

I am not detecting hardware failure on my computer, but my GPU was loosely connected for some strange reason and that was causing problems even outside of Fedora, still, Ubuntu and Windows 7 does not experience this and yet with Fedora it is a problem…

I’m just telling you what your motherboard manual says is happening. It could be very likely that nothing is directly failing, or something could just be loose.

You’ll need to investigate, but hopefully I got you onto the right track.

1 Like

first replug the gpu, cpu, ram, power cables, etc. if that does not fix it then try running a memtest

1 Like

His mobo has built in tests for his memorey


I doubt this is a hardware problem. The R9 390 seems to have problems on the radeon driver. I had the same experience with my 390 on fedora and Ubuntu. Unfortunately my 390 was only usable with fglrx. You can try compiling the kernel to get the AMD GPU driver to work. I believe there are some guides on this site on it, but I myself have never tried it.

Bug 91880 - Radeonsi on Grenada cards (r9 390) exceptionally unstable and poorly performing

no need to recompile kernel. support for volcanic islands has been integrated as modules into the kernel (>=4.10)

AMDGPU works out of box with new installations.

I discovered this myself.

I might just simply sell my R9 390 and go for something else (RX 560, if I am lucky, an RX 470 4 GB since I am downsizing on the monitor as well.

Wait, when was this? Because I tried to use Ubuntu (I wanted to use Fedora but Fedora had even worse issues with the card which made it unusable) and I had nasty performance issues and screen tearing.

its been a thing, for awhile.

Should not be using fglrx as they deprecated.

Radeonsi is for cards that predate volacanic islands.

again, what compositor were you usuing? :stuck_out_tongue:
What ubunut, theres tons of them.

That’s just it, my GPU is not using fglrx anymore, it is using radeon. I was using Ubuntu GNOME 16.04.3, is there a chance that GNOME might be negatively reacting towards the new drivers?

You should be using amdgpu

do this to see if its on your system already

dmesg | grep amdgpu

If its not empty then its already on there.

I am not at home unfortunately, I will give it a go when I get home.

alright, and when you get home check your kernel version.

uname -r

amdgpu is in >=4.10 kernel versions.

Trouble with the LTS versions is that they use old kernels, and they don’t always work for newish hardware.

BTW: @DrewSaga
arch wiki on amdgpu

amdgpu is the open source graphics driver for the latest AMD Radeon graphics cards.
At the moment there is support for Volcanic Islands (VI) and experimental support for Sea Islands (CI) and Southern Islands (SI) cards. AMD has absolutely no plans for supporting the pre-GCN GPUs.
Owners of unsupported AMD/ATI video cards may use the Radeon open source or AMD’s proprietary driver instead.

a R9 390 is a Hawaii gpu, so volcanic islands. You should definitely be using amdgpu and not any other driver.

And I just checked from your previous post and it said you were running kernel 4.11 in which case you should be using amdgpu. But when you get home please check to make sure. If you’re not, then I think I know what is your problem.

Okay, I checked the drivers, running dmesg | grep amdgpu

[ 6.410808] [drm] amdgpu kernel modesetting enabled.

running uname -r gave me


The weird thing is I am not seeing screen tearing. This strikes me as quite strange, something about my 4K monitor maybe that Linux doesn’t like. Or is there still an issue but it’s mostly with the high resolution? Never really thought my monitor would be the problem since Windows ran fine. I am going to test this with a couple of computer games and another program as well as an emulator.

The 00 code you mentioned won’t mean anything. Linux doesn’t talk to it properly so once booted 00 might be expected.

Yeah, took me a long while to notice that.

@Eden where is your self hosted wiki at these days?

I had a thread about power issues causing system hands and I think its relevant here.

Thats my bad, I recently fiddled with the timers for auto-renew and they didn’t seem to trigger. Try now.

Status is the same, im not overly promoting it as wendell wanted to do something, but im keeping it up until then. (maybe prod him :stuck_out_tongue: )

1 Like