Return to Level1Techs.com

Clonezilla, timeshift and other backup issues

So I have been trying to make backups of my Arch Linux install. I have tried several tools in Linux as well as Clonezilla and they all have failed in one way or another. Clonezilla gives this error when I try to check if the backup is restorable The image of this partition is broken: nvme0n1p2 Timeshift freezes on the calculating system size right after telling it to create a backup. BackInTime seems to be working although for some reason I can’t get it to make automated backups. Idk if the backups its making is clean though, it doesn’t seem to have an option for checking the backups. kup (a kde frontend to bup) was working fine although I was only able to use it to backup user files, not the system. However, kup randomly started failing now I don’t know why I tried removing the backup folder and letting it recreate it but it still fails at about 80%.

I have tried running fsck on the disk and it says it’s clean

For backups, try rsync (on Arch), provided your backup runs Linux/Unix as well. See the rsync man pages for syntax and the myriad of options.

i was looking at the man page and the archwiki and it seems a little difficult to do what I want with just rsync which is why pepole created frontends like timeshift i guess.

basically what i want to do is take incremental snapshots of my system to be able to restore in case a update messes something up or im tinkering and break something. this backup has to exclude my user files, but include the .files in my home directory. (so the .config .local etc)
and then another one that just backups the non .files in my home directory. (this one is easier i think)

clonezilla was an alternative to this because i have my home and system partition seperate so i could just make an image of my home and another of my system and another of my boot and chosse which ones i want to restore

I’m actually using rsync to copy my home folder to an external server (still on local LAN though!)

rsync -rtvu /home/<user> <[email protected]:/full/path/to/target/>

Rsync only transmits changed files since the last sync. If snapshots are important, consider converting your /home directory to BTRFS or ZFS, these offer snapshots by default.

Rsync is not a backup. It does not maintain versions, and every time you run it, the entire directory tree from the source is mirrored exactly to the destination.

While that’s fine for synchronization, you really need a more robust solution for backups you can rely on.

There are a few out there, but my personal favorite is Restic. It’s very barebones, though, so cron jobs are your friend.

I’ve got a guide in the works for this, hopefully it’ll be ready in a couple days.

2 Likes

I can’t change the file system of a partition without reformating though no?

I have tried restic also couldn’t get it to work either forgot what was the issue for that I been at this for about a month ever since I switched from Manjaro to arch

1 Like

Maybe the guide will help

1 Like

No, you’ll need to reformat the partition.

I’m aware of the risks of using rsync as a backup tool being bitten in the past, loosing a considerable amount of data, but I also know rsync has an option to create a backup archive of sorts, IIRC it’s the -b flag.

Incidentally, one page I’d looked at for rsync also had a few recommended/related links, in this case to Grsync (rsync GUI) and rsnapshot.

HTH!

yeah ill be on the look out for that thanks both of you

1 Like

rsnapshot is great, and mitigates the concerns I pointed out above. +1 for this.

You can convert ext3/4 to btrfs, but I don’t recommend btrfs due to stability issues.

Btrfs still has stability issues? Fedora is considering ( I think it might of been approved) switching to btrfs

I don’t use it cuz it doesn’t work with games and steam and I don’t care about having to use a tool and wait like 5 min to make a snapshot vs having it built in to the FS and be instantaneous

This is really strange apparently, making a backup and telling it to check the image after the backup fails, but trying to restore that backup and using the option to check the image before the restore works just fine no issues.if I later go back into the clonezilla menu and select the manual image check it fails… Which is it? Is it borken or not😖 this makes no sense

Might have figured out the issue with clonezilla, the issue was that I was compressing the image with zstd and that causes the issue. If I use the default gzip format I get no issues

Last I checked, it’s still in consideration.

The big stability issue is in raid56. It’s not really single disks, but I’ve noticed that crappy SSDs that don’t report properly are causing a lot of people pain with BTRFS. There’s a thread on the forum right now, where someone was having btrfs pains.


Last I checked, it does work with steam/games. Not sure where you got that impression from.

I may be wrong though, I haven’t used it in a while.

I’ve had nothing but success with zstd on clonezilla. Are you using the live image or the package?

I’m using a live image but I’m using netboot .xyz which let’s me boot a bunch of different Linux distros and stuff. I have that as a launch option in refined. So that downloads the latest image into ram. Maybe that’s why it’s having issues with zstd

Oh, that’s neat. Never knew about netboot.xyz.

still was never able to find out why ztsd compressed images do not work for me. It would be nice to fix this as it is faster and smaller than gzip

solved it the issue was that I was creating the backup on the root folder of the drive and for some reason clonezilla didn’t like that if I was also using zstd compression

1 Like