Chelsio T520-CR compatibility

Hi

I have a Dell Chelsio T520-CR and I would like to use it on a server running FreeBSD.

I currently have a Dell PowerEdge R320 that I use for testing and studying, but it turns out to be incompatible with the T520-CR NIC causing the R320 to completely freeze at boot time and not even able to enter BIOS.

I have thought about an old HP ProLiant ML110 G5, do you think it could be compatible? Does anyone know of any equipment with PCI-Express x8 that can serve?

I don’t know which server might be compatible, and I wouldn’t want to buy one without knowing it.

Thanks.

I was going to ask if you’ve tried updating the firmware but that requires you to your box booting.

I wonder if it’s this you might be seeing?

https://service.chelsio.com/beta/drivers/Chelsio-Uboot-2.0.0.24/Chelsio-UnifiedBoot-UserGuide.pdf - Supported hardware sections suggest that you might have a BIOS issue :-/

2 Likes

Thanks for helping.

I understand that from what I see in the PDF you just shared with me, only the devices on the list are compatible with the Chelsio NIC.

I think I will buy a PowereEdge R220, I will leave my R320 since I use it to study ZFS.

But it’s funny, when I go to the DELL website and search for R320 drivers with the keyword Chelsio, absolutely nothing comes up.

Well, I think that acquiring a server from the list will solve the problem, the IBM link is exactly what happens to me, and apparently what cannot be solved, since they are permanently incompatible.

The same could be applied to my R320.

Thanks

If you can enable legacy mode (often called CSM) only it should be able to boot from what I can gather or/and if you can get it working in another box so you potentially get a newer firmware into the card itself.

My R320 is in Legacy mode, I can see how the Chelsio NIC processes load like these:

Chelsio Unified Boot BIOS v1.0.0.90
Chelsio Storage FCoE Bios is Disabled or Boot Ports are all set to NONE
Please run Chelsio Unified Configuration Utility
Chelsio Storage iSCSI Bios is Disabled or Boot Ports are all set to NONE
Please run Chelsio Unified Configuration Utility

But when R320 loads firmware and continues with the process of booting the operating system its freezes.

As described in the IBM error, and of course, the R320 is not in the list of compatible servers, so the solution is that right?

Sorry if I have not understood you correctly, are you telling me to update the firmware of my chelsio NIC?

Create a boot disk as the manual says and use the option Chelsio Unified Configuration Utility?

But I think with the NIC installed, I can’t boot from any device. I can’t start any system, my r320 freezes.

Thanks again.

Edit: I don’t have another machine, to be able to connect my NIC Chelsio, only the R320.