Changing Distro's

I had a great post but all I get is error 403 Forbidden. When I try to post it.

Have a shot at my post. :(

Write it down as a .txt file and attache it to this post if you're getting this kind of problems. Or just link the same .txt file from your Dropbox/Google Drive/One Drive/whatever. What was it all about?

Certain key-words are filtered by the internal system, resulting in the 403 Forbidden message.

try to remove/change things like /etc/ passwd (wont work without space)

or use pastebin or similar

Long story short.

I decided to check out Antergos. Everything is fine except I cant get virtualboc or virt-manager to work. I use VM's a lot so that is a need.

Virtualbox
WARNING: The vboxdrv kernel module is not loaded. Either there is no module
available for the current kernel (4.4.5-1-ARCH) or it failed to
load. Please recompile the kernel module and install it by

       sudo /sbin/rcvboxdrv setup

     You will not be able to start VMs until this problem is fixed.

VirtualBox: supR3HardenedMainGetTrustedMain: dlopen("/usr/lib/virtualbox/VirtualBox.so",) failed: libQtCore.so.4: cannot open shared object file: No such file or directory

So I ran the command
[[email protected] ~]$ sudo /sbin/rcvboxdrv setup
[sudo] password for marten:
Unloading modules:
Loading modules: modprobe: FATAL: Module vboxnetadp not found in directory /lib/modules/4.4.5-1-ARCH
modprobe: FATAL: Module vboxnetflt not found in directory /lib/modules/4.4.5-1-ARCH
modprobe: FATAL: Module vboxpci not found in directory /lib/modules/4.4.5-1-ARCH
modprobe: FATAL: Module vboxdrv not found in directory /lib/modules/4.4.5-1-ARCH

And Virt-manager
Unable to connect to libvirt.

Verify that the 'libvirtd' daemon is running.

I asume I cant run a bleeding edge disto and have VM's ?

Alright, let's see what I can do.

As far as virt-manager goes, you'll need to start the libvirtd and virtlogd services.

You start services with the following command:

sudo systemctl start <service>

and you have them run on boot with

sudo systemctl enable <service>

So, you'll want to do:

sudo systemctl enable libvirtd
sudo systemctl start libvirtd
sudo systemctl enable virtlogd
sudo systemctl start virtlogd

And you'll be able to use virt-manager

Now for virtualbox.

For the rcvboxdrv issue, we need to downgrade the kernel, since virtualbox doesn't make drivers for kernel 4.4.5

Arch makes a LTS kernel, which is currently kernel version 4.1.20 and was updated on the 19th of march.

To do this, you'll just swap kernels with:

sudo pacman -S linux-lts
sudo pacman -Rs linux

Once you've installed the new kernel, restart the computer and you can run the command again, which should work.

sudo /sbin/rcvboxdrv setup

For virtualbox, the GUI is an optional aspect, and qt is an optional dependency of virtualbox.

to fix your issue with virtualbox, you'll just install qt and you should be fine.

sudo pacman -S qt

Hope this helps!

You absolutely can run bleeding edge and have VM's. Also, Arch is only more bleeding edge than Ubuntu in the idea that the packages are up to date. None of the packages in Arch are unstable. (unless you use the testing repo)

EDIT: apparently you're also having some issues with the virtualbox kernel modules. Looks like we're going to have to downgrade the kernel to get support. (sometimes this happens, so to be safe, let's stick with the LTS kernel)

Thanks for the reply sgtawesomesauce :)

Im trying out your fixes but I kinda wanted to stay kernel 4.4+. It was the point. Since my BTRFS drive pool is working no matter what i do. I can at this point install / reinstall no problem.

Should I as a novice go to ubuntu 16.04 beta which ive been waiting for (16.04 release) but got itchy feet :)

Ah. I see. Maybe it's best to just stick with libvirt then.

I think you'll learn more and have an easier and more rewarding time with Arch/Antergos. The thing about Ubuntu is that it's designed to work, but once you start playing around with it, the distro keels over, dies, and it's very hard to resuscitate it. With arch, everything either works, or there's a wiki/forum topic explaining how to fix it.

And if you still want Ubuntu, there's nothing stopping you from dual-booting (or triple or quad or quint booting for that matter). I've got a guide in the works explaining dual-booting on subvolumes with BTRFS.

Also, arch has a tendency to teach you critical thinking with regards to GNU/Linux. With Ubuntu, and my guide up above, the answers are just given. I explained to you why they are, but I still gave them to you. With the arch wiki, it makes you do a lot of reading and figuring out on your own. If I were the archwiki, I would have linked you to the troubleshooting section of virtualbox and libvirt, and linked you to the systemd page and told you to read them and figure it out.

Don't get me wrong, I'm all for helping people come to quick answers, but at the same time, I believe that Arch provides a better learning environment for people.

Ok...

Im going put my brain vs it with lots of Google's

Virtual Manager running but tossing :
Virtual Network 'default' is not active. Would you like to start the network now?

Yes does nothing.

Ill eat, sleep and poop, Then google away again.

Sounds good. I've had issues with this in the past, but for some reason, it "just worked" for me on my latest installation, a week ago. I'll throw my head into the wiki as well. This is usually some stupid thing that's causing it.

Google this and nothing but an ad. Its python sure but my machine is on the internet and working.

Traceback (most recent call last):
File "/usr/share/virt-manager/virtManager/netlist.py", line 361, in validate_network
netobj.start()
File "/usr/share/virt-manager/virtManager/libvirtobject.py", line 83, in newfn
ret = fn(self, *args, **kwargs)
File "/usr/share/virt-manager/virtManager/network.py", line 81, in start
self._backend.create()
File "/usr/lib/python2.7/site-packages/libvirt.py", line 2952, in create
if ret == -1: raise libvirtError ('virNetworkCreate() failed', net=self)
libvirtError: internal error: Failed to initialize a valid firewall backend

There is packaged called firewalld in archlinux, veriy if you have installed and start and enabled it with:

sudo systemctl enable firewalld
sudo systemctl start firewalld

FYI, you can run virtualbox on Linux 4.4+ without issues, you have to make sure the modules are build for each kernel update and that the modules are hooked into the loading of the kernel as per the wiki (i asusme its on there)

Your better with KVM though if you can.

Nothing to add for Arch im afraid as ive not used it in a while.

I eat , pooped and slept. Im dealing with iit now.. Gnonme-boxes runs VM's of all things. So I known it possible