Can't scroll with Down Arrow key!

Iam able to scroll with the UP Arrow, to go left and right in my WordPad even up but not down!
I had this issue with my old Sharkoon Skiller, why I changed my keyboard is because of this issue as I thought It was the keyboard which was broken.. Now I have an 130 euro Blackwidow Ultimate 2014 from Razer and have the same Issue..

Tried to press F7,F4,Function Key. Nothing worked! Every time I hold down arrow while in WordPad or Notes the words dissappear for 0.1 sec and appear again like it would refresh or something..

Help paid 130 euro because of this stupid issue!

I would say that your scroll down is moving too fast, it gets to the "bottom" so quickly that windows does the retarded thing where scrolling all the way to the bottom really fast, for some reason makes it go back to the top.

That's the only thing I can think of that would make the words "disappear" and then re-appear as though it was "refreshing".

As far as a fix goes....I've no idea.

I made a video where you can see it happening..

have you made sure that scroll lock is off? (stupid question, I know. Not even really sure what scroll lock is actually for)

Other than that, I'm out of ideas.

Edit: just looked it up. Scroll lock was originally intended to change from the arrow keys moving the cursor to scrolling the scroll bar, so I would check that.

Try what you just did in that video, but a lot more test. Enough that you have a lot of scroll bar on the side, and see what happens.

Nope, nothing changed.