Return to Level1Techs.com

Cant "overclock" RAM on MSI X570 pro carbon

my set up is
MSI MPG X570 GAMING PRO CARBON WIFI
Corsair LPX 32GB 3200mhz cl 16 v4.1 ( 2x16GB samsung b-die) x 2
ryzen 9 3900x
currently BIOS : 7B93v124

it seems that when ever i set the recommended timings and voltage i get “Memory Overclocking Failed” and then i reboot a few times and then it works sometimes…
when it works , then i stresstest the memory , CPU or run benchmarks and all is fine.
I let the computer go to hibernation and wake it up, no errors every thing is dandy.
i then reboot the system and boom i go into the “Memory OVerclocking faild”

i have both experienced it with 2933 and the 3200 .
i have tried the Dram calc, tried 1 Stick , 2 sticks and all 4 sticks and it is still the same.
and i tried all the BIOS’s.

anyone else experience this ???

Are you certain that is B-Die? That doesn’t seem right but I could be wrong.

DDR4 tends to be more picky with subtimings, so if you leave them on auto and only change the main timings it might not work. XMP may also not yield advertised speeds. I haven’t personally used it because I’m on Linux, but there is a DRAM Calculator For Ryzen that is supposed to help give optimal settings. There are very savvy DDR4 overclockers there if you still need help.

I tried the Dram Calc but to no use …
And yes i am sure :slight_smile: got it through CPU-Z program that they are :slight_smile:
its not that the speed is the big thing, but it i would just prefer to be at the Adviced speed :slight_smile: .