Can't load up gta 4 only goes to social club

hi all 

im having a problem that gta 4 doesnt load up only goes to the social club sign up thingy i signed in then it just doesnt load the game i have found a problem that was put files in the files of the game but it stayed at 800x600 and im at 1920x1080


can anyone help i really want to play this game

Ok so gta 4 is very weird i always have problems with it but i think you are having the same problem as me if it just stays at a black screen just wait awhile it will take like a minute to load (Which sucks) And if that dosn't work just Google it most people have the same problems with this game you should get a good response from that,

its doesnt even go to black screen its just quits after social club but ill hopefully find a waythanks


can anyone help me it wont change from 800x600 i tried adding the text notes to the files of the game

can anyone help plzzz i dont want to play at 800x600 for the rest of my life i need it at 1920x1080

i have a r9 290, fx8320, 8gb 1600mhz ram its says im using to much ram but i can run bf4 at ultra 70+ fps ?

Maybe the problem is about the firewall restrictions or GFWL, check that out, if not, I will tell you the same I did with AC IV, now that you have it, go and pirate it, it's not illegal anymore if you have a copy of the game purchased. there are some patches that jump the social club fuss. I had the same problem and I solved it that way, but I'm not buying any Rockstar games anymore until they fix it. 

Btw.. I found this... look in the comments and they have a "tutorial" on what do you have to do, if that doesn't work, say it :) Good Luck

thanks i have it up and running but its stuck at 800x600 if i download anthor copy will that help