Cant launch BO2 Multiplayer?

when ever I try to laucnh Black ops 2 MP through steam it doesnt work the console comes up and says 

 

" Unhandled exception caught "

 

I have tried verifieing the game cahche on the campaign, zombies, and multiplayer. none of them launch..

 

 

Any Ideas?

try disabling your sound card (just to test) , launch the game and see what happens.

How do I go about doing that? just go to sound devices and disable it? (I have the soundblaster Z)

http://www.newegg.com/Product/Product.aspx?Item=N82E16829102048

control panel > device manager > sound,video and game controllers

right click on your soundcard and click disable (the enable option is in there aswell so you just click that to turn back on)

I posted this before but i really feel everyone that plays black ops 2 should watch this video. http://www.youtube.com/watch?v=ZoFnIckyoxg

Sorry I didnt reply sooner, I was at work.

 

I just tired that. no difference :/

 

game crashes and shows that same error again

Still have no Idea, Ive tried uninstalling and redownloading. still fails..

Saw that some guy removed his sound card and it worked, also try cahnging the date and time (in your system tray) because i heard that can work too

I tried the sound card,nothing changed.

 

I ahvent tried system time. will try that in a few

COMPLETELY formatted my SSD and reinstalled windows and steam. then redownloaded Black ops, zombies, and multiplayer. I tried to launch it. Still that same error!

What am I doing wrong?!

What kind of mobo do you have? I ran into a similar problem a month ago. My mobo is a evga x58 ftw3, and I have two eternet ports on it. At one point I was using my 2nd port to give internet to my laptop, because of that I was not able to log onto bo2. Try looking at your network settings on your computer and router.

My friend and I were just talking about SSD's and formatting them.  I should ask...did you "Quick format" or "Full format"?

okay guys I ended up figureing it out, my GPU (nvidia GT240) was causign the problem. I can launch it with onboard video. i am uying a new GPU this weekend

The flying spaghetti monster is trying to tell you something. I really don't know. The first thing i try is run as administrator. Another thing you could do is right click the game in your library, select properties, and then select "verify integrity of game cache" under the local files tab.