Cant install os on new build

hi everyone, i have just built a new pc and when i try to install any kind of os it just says "reboot and select proper boot device or insert boot media in selected boot device and press a key" i have tryed this with different discs, one being win7 and other being ubuntu, and the same thing happens each time, i have also tryed using a usb with win7 on it and i get the same thing, it is very annoying as everything is brandnew

the specs are:

asus sabertooth 990fx r2.0

AMD fx-6300

8gb kingston hyper x ram

lite disc drive

HD radeon 6450 (have a gtx 295 but not installed yet)

antec 650 earthwatts

WD cb 320gb

seagate momentus 320gb

hitachi deskstar 500gb

please help

thanks!

Have you attempted this via USB installation and still received the same negative results?

Make sure all your plugs are in properly, and check your bios to make sure that everything is recognised.  I had this problem when I had a loose power connector on my hard drive.

i have tryed it via usb and the same problem, i check all the leads and the bios does recognise the disc drive or usb stick and the HDD's

 

have disconnected and reconnected the leads to hdds and still same problem, could it be something in the bios? or even the bios version?

I would recommend updating your BIOS and trying again, though it may be a bit difficult to do so without an OS.  I've yet to update my BIOS without an OS's assistance.

okay thank you, il try to update my bios and let ye know how i get on, thanks

updated my bios to 1503 and i still get the same problems, could it be the mother board or disc drive?

Have you tried doing this with a different disc drive installed?

i have not as i dont have one handy, but i will be getting one to try i with tomorrow

i have not as i dont have one handy, but i will be getting one to try i with tomorrow

Try disconnecting everything except the disc drive.  No other hdd's or drives.  What is your boot order set to?  

 

This message is the bios telling you that it's looking for something that can be bootable, but it's not finding it.  So it's not recognising your dvd drive, or your dvd drive is not in the boot sequence. Or, I guess, third option, something is broke.

i have done this, the disc drive shows up in the bios boot order, i tryed a different drive and still the same hing, i figured the mobo must be acting up so iv sent it back for a refund

Nope. I just had this problem with my new build a couple of days ago. When you're installing from a USB, you have to set the USB to boot as a hard disk. That's what showed up in my BIOS, and it worked. Try that when you get your mobo back

if i get the same probelm again with the new mobo i will try this but i am hoping i wont have to, thanks though