Can't install from PPA on ubuntu server

I’ve been trying to install software from a PPA onto ubuntu LTS server 17.04 and it isn’t working, when I run

sudo apt-get update

It results in apt telling me that it can’t be trusted (the repo) due to a lack of a release file, and after following the instructions of going in and creating an apt.conf file to apply the change which allows it take from unsign repos, it still won’t update to allow me to install. What am I doing wrong here?

did you get a gpg key?

Yeah, it was added when I did the add-apt-repo command

EDIT - let me try this again. Is it 16.04 LTS or 17.04? Which PPA?

17.04, handbrake

Not certain what is going wrong. It worked for me trying to install it on 16.04. 17.04 is past it’s life cycle by now, although I don’t know if that affects this particular situation.

After running in circles needlessly, I just typed in .deb handbrake in my search engine of choice and found a newer version on the Debian website than what is in the PPA (1.0.7 vs 1.0.4):

You can pick your architecture at the bottom of the page and get the .deb. I know some people say not to do that, but they also say not to use PPA’s, so I’d imagine a .deb file straight from Debian is at least as safe as the PPA.

Basically got around this by finding the .deb, thank you for finding one so up to date