Can't install fedora 26

I have a crosshair 6, 1800x, 2x16gb ram, 1tb m.2 ssd and a gtx 1080ti FE, I can’t seem to install fedora 26. The image works on my laptop yet My desktop can not get to the install part of just loads a bunch of command line and then it just hangs there untill I power it off.

I do have the latest bios update. and the latest image from the website. Is it my motherboard? Or is there a bit information I’m just missing. I’d appreciate the help :frowning:

Do you have multiple monitors connected to your desktop?

double check m.2 bios requirement. i think i had the same issue a while back using m.2 laptop. i cant recall. like @EarthMadeOfGlass stated if your running multiple monitors try only using 1x. also sometimes my dvi only works during setup… i know strange

I guess I should’ve pointed that out versus being a snob ass. I’m pretty sure it happens because you’re using the open source drivers upon installation. You should actually be able to grab the drivers from the software store in gnome but if you need a guide I suggest this guy


Thank you all for the Support. I tried a lot of different troubleshooting steps. But I think it might be something else. I tried to load Ubuntu 16.04 LTS and 17.04 with no success. I tried different drives that I have laying around with no progress. I’m starting to think It maybe be UEFI related. but I’m not 100% sure.

try adding the nomodeset option to the kernel command line when booting fedora. sounds like the GPU cant display to the screen


This is essentially what happens when trying to install fedora. I let it sit for about 2 hours a while back to see if anything happens but It just sits here. I hope this is useful lol

I agree with the nomodeset option above.

When you load the USB installer, when you get the options to “test the media” or “install fedora”, highlight “install fedora” and press “E”

You’ll want to go down to the field that starts with “linux” – It might look funny, but it’ll say linux /boot/somethingsomething/somethingelse … quiet splash

After the quiet splash (sometimes it will just say “quiet”), add nomodeset

Press F-10 – If nothing happens, press Control-X

This is necessary sometimes when you have a bad ass graphics card lol.

1 Like