Return to Level1Techs.com

Can't get Steam to work on ZFS dataset

Using Arch with ZFS as rootfs here and I encountered a pretty annoying problem.

It appears that Steam is unable to recognize my datasets as usable space as it throws an error message, telling it needs 250 MB of disk space in order to update. I tried creating a zvol which I formatted with ext4 and mounted it at /mnt/steam. Then I symlinked the Steam files to that location but that couldn’t fix the problem.

This prevents me from testing my game library against Proton on bare-metal. Any idea what else I could try?

Set a quota on the dataset where steam is installed and it should then work, I had the same issue:

sudo zfs set quota=1T pool/dataset

Substitute for your settings.

1 Like

yes there is a bug with steam and ZFS, where it sometimes sees ZFS partitions as having 0mb free.
setting the quota as @Asgaroth suggests might do the trick, i never managed to solve it though, and ended up using a image file, formatted in ext4, and mounted as a folder instead.

1 Like

Amazing! Setting a quota on my home and system directories did in fact solve my problem. Thanks a lot!