Can't get realtek 2.5 gb lan to work with linux on asus b550 board

I just built a new machine with a Desktop Gigabyte B550 AORUS ELITE AX.
My wifi works but I cant get the ethernet to work. It seems that Linux mint isn’t playing nice with the realtek lan chip. I have tried the linux driver from realtek repeatedly. Upgrading to a 5.8 kernel. Backing up to a 5.4 kernel.
Still no change.
Does anyone have a suggestion?

There is are different variants of the RTL8125. The Aorus Elite has the b variant which hasn’t been supported before 5.9. I have the same board so I was surprised to find that out since technically the RTL8125a is supported since kernel 5.1. You can manually install the driver though.

Go to Realtek PCIe FE / GBE / 2.5G / Gaming Ethernet Family Controller Software - REALTEK and download the “2.5G Ethernet LINUX driver r8125 for kernel up to 5.6” package, unpack, compile the module and you are good to go until your distro updates to 5.9.

1 Like

Thank you for the tip. i have tried that repatedlyu and it fails.
Can I just force an update to the 5.9 kernel

You are probably missing a devel package, that you need to install. As far as Mint is concerned I don’t know if there is an updated easy-to-go kernel package available.

I forced the kernel update using ubuntu directions. That fixed it and so far no other glitches.


This topic was automatically closed 273 days after the last reply. New replies are no longer allowed.