Can't get amd hd 7870 to crossfire

he guys im wondering if you guys might have some advice for me i''ve got two hd 7870's but i cant get them to crossfire within the catalyst control center i'm running the latest drivers though and it should underneith game but it isnt if i go to hardware it says disabled adapter ans that is the second graphicscard but when i go to gpu-z it detects the card and in windows computer management it's also enabled. i have tried allot already taking one card out and reinstalling the drivers and putting it back in and reinstalling the drivers with both cards installed and also switching the places of the cards (top/bottom bottom/top) all has not worked :( so do you guys know how to fix this problem??


The 7870s are notorious for xfire setups.There was a video where Logan tried to do some benchmarks with xfired 7870s,but he couldn't get them to work.

Yes thats right i've seen that videp but is there a solution to this problem?


I have two R9-270x's in Crossfire right now. they are basically 7870s. I haven't had problems so far.

Check if You have the Crossfire Bridge on the 2 GPUS are Properly Connected, check if they aren't loose. then Go to the Catalyst Control Center

Go to the Gaming Tab assuming you have your Catalyst Control Center on Advanced View. and Enable Crossfire and then check Enable AMD Crossfire for Applications that have no associated application profile.

If you have the Catalyst Control Center Set to Standard View go to the Gaming Menu, then click it. under gaming performance click AMD CrossfireX and Same instructions.

Enable AMD CrossfireX

and Enable AMD CrossfireX for Applications that have no Associated Application Profile.

For what ever reason, somethings mislabel crossfire as not on . Not something to worry about if turned on in calalyst.

I know that i have to do that but the weird thing is is that crossfire x isnt there only 3d applications under the tab gaming 

Install 2 crossfire bridges (yep you read that right). I had an odd pair of 5770's in xfire in a build years ago that wouldnt work without 2 bridges installed. Worth a shot.

Otherwise, uninstall drivers, remove devices (device manager), reboot, install drivers ........>

Yeah i only have one crossfire finger so that is not gonna work and i have done that already and it didnt work :(

Just a quick question, does your motherboard even support crossfire?

If not then you're in a pickle, if it does then it may be worth checking out to see if there is a bios update that has been released to resolve such an issue.

If your going by the ccc, and your using the latest drivers your second gpu may not show up on ccc as being there. Try using the beta if you really need the second gpu to show up in ccc. If you have any doubts about whether its working or not, get gpu-z and use it monitor your cards. Temps and loads tell the story.


jep it sure does support crossfire x its an asus crosshair v formula-z

yeah when i used the latest drivers i didnt get a control centre and i am running the beta drivers now i have downloaded gpu-z and it does detect the card but it also says crossfirre is disabled so offcourse it doesnt do anything right now ;(

hey guys

i was wondering if i uninstalled windows and took one card out and reinstall windows install the drivers and then put in the second card could that solve the problem? because i read it somewhere that that could work

Still have to turn on crossfire in performance options.


When all else fails Google it.

My HD7950s gave me some grief, black screens and blue turned out to be ULPS settings in the reg. Google how to disable ULPS and try that from what I read it should be disabled for crossfirex any way. I did have to turn off power at the PSU  for about 10 seconds and back on, then boot after the ULPS was disabled.

The more i think about this, I have to ask the question. What is telling you that crossfire isnt on. If its not ccc, then maybe you shouldnt take it to heart and just monitor how your gpus are being used with gpu z.

Hey freaksmacker gpu z is telling me that crossfire is disabled and in ccc i dont have the option to turn it on the whole option isnt even their its not greyed out it isnt their thats the weird thing about it when i go to the info tab in ccc and press hardware it shows the first graphicscard but the second graphics card is labeled as 'disabled adapter'

Hey trevsstrem i have just done that and that doesn't work either :( it still says disabled adapter in ccc :(

Double check the owners manual for correct crossfire placement options for your board. Other than that,  i am stumped. It should be way easier that. Admittly, amd software has been kind of incomplete . The crossfire option should come up on first boot after a software install. It should detect it and popup your crossfire options.