Cant get 4k 60hz in Linux

I'm using a RX 480 and no drivers seem to work with, Debian, Mint or even Ubuntu to get 4k 60hz (over HDMI) I've spent 12 or so hours attempting to get it working to no avail. Do you people have any ideas?

For the moment I'm performing a feasibility assessment of only using virtual machines inside a dedicated host to act as a hypervisor. (to make my daily driver secure, portable and easy to backup) Also maybe I just want an excuse to have some epic hardware.

1 Like

Have you tested out Windows?

Is all of your ports HDMI 2.0?

Yeah they are all HDMI 2.0. and I'm trying to move away from windows... if at all possible. The AMDGPU-PRO drivers don't install on Mint 18 and Debian for me. But on Ubuntu they start and fail without giving me messages they it failed. And none of the stuff that comes with Mint or Ubuntu and worked at all either.

(I rarely play games and have been using Mint on my laptops for a year now)

I'm surprised it's not working on Ubuntu.

I'm 90% sure that AMDGPU-Pro came out targeting the RX 480 and Ubuntu 16.04.

Have you tried getting the latest Mesa drivers instead through the PPA? https://launchpad.net/~oibaf/+archive/ubuntu/graphics-drivers

Also, have you tried a different cable? Putting the RX 480 in a different PC?

is it possible that you're using a cable that doesn't cover the 2.0 spec? Apparently that's a thing now.

Are the drivers just failing to install, or are they installing and then refusing to push 4k?

do you have error logs you can post?

4 Likes

Two possibilities. Support isn't in yet because it's currently in the DAL patch which hasn't been accepted in kernel yet (probably 4.12, but you could enable it yourself by compiling the kernel).
Or the monitors specific weirdness hasn't been caught and patched yet.

There's a few bug reports around if you search for them.

2 Likes

You should be spinning your own latest Mesa build drivers, like latest ones, or those from that community resource I can't remember.

Also rx480 isn't a [email protected] videocard for most things.

For the PRO to work in its latest version you need to update the kernel to over 4.8, either in Ubuntu or Mint.

I would propose to go for the Open Driver stack as the performance now is comparable to the PRO and it is improving with every version.

Use sth like ukuu to update to kernel 4.9 and then update to the latest MESA (dev) using this PPA:

https://launchpad.net/~paulo-miguel-dias/+archive/ubuntu/mesa

This would give you the best performance out of the card. Not sure of you get your 4K 60hz yet but it should get there as the driver and the kernel modules improves.

Of course if you want the stable version of MESA for less risk you can use this PPA first. It should give similar performance :

https://launchpad.net/~paulo-miguel-dias/+archive/ubuntu/pkppa/

2 Likes

https://bugs.freedesktop.org/show_bug.cgi?id=98333

First thing that comes up. It may be dependent on the screen, but you can try with dal patches

1 Like

They just refuse to push 4k 60. when i use xrandr its not a available mode. and wont allow me to set refresh higher then 24hz. Also 4k 60hz works fine under windows so I don't think it's the cable. (have confirmed with ufotest)

so you get 4k but only 24hz? what driver version are you trying to use?

Thats correct. When I just attempted to add a new mode to xrandr and it dropped the screen until i changed it back and did a reboot

Some modes with incorrect/incompatible hsync and vsync settings might cause that. Test these settings (replace DP4 with you output port):

xrandr --newmode "3840x2160_60" 534.010 3840 3982 4027 4064 2160 2170 2180 2190 +hsync +vsync
xrandr --addmode DP4 3840x2160_60
xrandr --output DP4 --mode 3840x2160_60

Use also cvt program to test other settings.

2 Likes

As tkoham suggested. What cable are you using and do you have another cable to try. [email protected] is the limit on the cable and a crappy cable my fall back to a lower speed.

Hey, this worked.
Unfortunately the screen flickers now at 4k 60Hz which makes it unusable.
Using an RX480 connected to 4k tv via hdmi2.0 and amdgpu-pro driver on ubuntu 16.04

In case it helps anybody, 50Hz is stable for me at 3840x2160.
This is what i used to enable it:
xrandr --newmode "3840x2160_50" 445.008 3840 3982 4027 4064 2160 2170 2180 2190 +hsync +vsync && xrandr --addmode HDMI-A-0 3840x2160_50 && xrandr --output HDMI-A-0 --mode 3840x2160_50

2 Likes

FTFY.

The commands I mentioned were required when I needed to use 60hz on intel and nvidia graphics. I finally tested this weekend with amdgpu and ended with similar result with yours when using hdmi.

However when using displayport with club-3d displayport to hdmi adapter it worked flawlessly, I didn't even had to run those commands as it detected 60hz automatically.

I'm using archlinux with 4.10 kernel with all packages updated, a samsung 40ku6000 tv and a msi gaming x rx480 to test this.

With the new 17.10 amdgpu driver, 60Hz @ 4k over HDMI works flawlessly for me. There's no screen flicker like I had running the 16.40 driver.
You do still have to manually create the new mode with xrandr though.

1 Like

I’m having the same issue on my RX460 on Fedora 26. [email protected] works fine over DP but not over HDMI (despite the fact that it works in Windows). I’ve tried compiling amd’s latest staging downstream kernel but it doesn’t seem to affect anything. I don’t think using AMDGPU-PRO is an option either since i’m on Fedora.