Return to

Can't find a Linux Distro work Asus ROG G75VW



For The Last Two Day I have Been Trying to install any Linux Distro on my Laptop with no success. The closest I came to getting Linux installed on this laptop was with the latest version of Kali, but I couldn’t get a GUI installed on it. As anyone tried to install any version of Linux on this Laptop?

I have disable fast boot and secure boot in EFI or Bios. I have two disks one has Windows 8.1 and the other I am trying to install Linux on it.


Can you be more specific on the issues and or errors you are having?


For some reason (Probably graphics related) My laptop wouldn’t install Manjaro, so i went with Antergos instead, (Without any errors) give it a try if you’re into Arch


Every Linux Distro ITry the computer crashes right in the middle of the install, meaning my laptop freezes right in the middle of an install.


Try pressing E at the boot screen and add nomodeset after quiet splash (sometimes just quiet).

Press F10 or Control and X to execute. See if you can get through the installer.

I wouldn’t install Kali bare metal. See if you can get Ubuntu or Fedora installed first.


I got Linux Mint to install on my Laptop, so far know problems, if I have any more problems I will update this post. Thanks for the help.


It might be related to the GPU if it’s looking for a UEFI compatible GPU or defaulting to the Intel chip by mistake.

Try disabling Secure Boot and booting into legacy mode (non-UEFI from the boot drive) if the options exist. You might also need to change the CSM setting (compatibility support module).


I was able to install Linux Mint on my laptop and it worked real good, but I had trouble installing a Linux version of an app I need, so I am going to try installing Ubuntu 17.10.


Success, I was able to install Ubuntu 17.10 on my ASUS ROG G75VW, except for a few random screen freezes it runs like a top. Anyone know If it is possible to upgrade the Linux Kernel. I think the random problems I am having is due to driver support. Finally, by upgrading the Linux Kernel to 14.4 and using the latest none open source drivers for the GPU installed on this laptop all my issues with Ubuntu 17.10 have magically disappeared.

If some is trying to install Linux Ubuntu on an ASUS ROG G75VW make sure the Linux kernel you are using is at least 14.4 and a lot of your issues will go away.


Out of curiosity what distros did you try?

On your additional question, you can update the Ubuntu kernel using the mainline ppa or similar for example. I wouldn’t necessarily recommend it though.


I tried Linux mint versions 18.0 and 18.3, kali the latest available, Fedora 27, and Ububtu 17.10. The one distro that worked without any issues was Kali, but I believe that was because it installed by default Linux Kernel 4.13.
Then I tried Linux mint 18.0 which would crash in the middle of the install, so time to try Linux Mint 18.3 and it installed without crashing in the middle of the install,but it wouldn’t, run a sertain app that I needed for work, but was supoted on Ubuntu, so I installed Ubuntu 17.10 and update the Linux Kernel from 4.10 to 4.14.4 and now so far no more driver issues and everything just work like it should.