Cant connect to home wifi - please help

Hey guys,

So I just finished building my pc and installing windows. I also installed the software for my wireless adapter (Linksys N600 Dual Band Wireless Adapter), but for some reason I cannot connect to my wifi. I can see that there are wireless networks available, but I cant connect to mine. Do I have to plug an ethernet cable directly to my PC in order to download updates, drivers, etc.?

That would be a good place to start, or download the drivers, etc. from another machine and place them on a flash drive. Whatever is easiest for you. Let us know how that works out for you. I had an issue with ethernet when I first built my PC. Turned out that I needed the drivers from Asus.

By the way, what OS are you running?

Try restarting your Wireless AP.
Check you don't have extra security enabled (such as MAC filtering)

I am running 8.1 standard. I tried installing my driver for my mobo but it said "This driver cant be installed on this PC"!

I have tried that and I made sure my MAC filtering is also off

Is that wifi adapter compatible with 8.1?

Go to the Command Prompt

First type in:

netsh wlan show interfaces

Look for these things:

  • Physical Address = wireless MAC
  • SSID = The Access Point you are connected to
  • BSSID = The MAC of the Access Point you are connected to
  • Signal = The percentage output is better and more informative than "bars". Signal Strength.

All this information is useful for further troubleshooting.

If you cannot even connect to a wireless Router then you may have to go into your setting and make sure they are configured properly. This is typically done by:

Control Panel > Network and Internet > Network and Sharing Center > Connections
Control Panel > Network and Internet > Network and Sharing Center > Change Adapter Settings

Then go into properties,
Disable ipv6,
make sure ipv4 is checked.

If you cannot get onto the internet but can obtain a valid IP address, then your DNS may not be leasing automatically from your ISP. (see below)

ipconfig /release
ipconfig /renew
This will remove the previous ip will reaquire a new ip address. Since you are on a private network you should be getting something like 192.168.x.x if it is anything other than that, then you may have to do a factory reset on your router. (Usually the easiest option, instead of sifting through all the possible settings in your router).

Once that is done, reconnect and then do a ping test. (see below)

record your default gateway

ping "default gateway" -n 20
take note of any slow times (>50ms) and any packet loss

if all appears normal ping a website
ping -n 20
again take note of any packet loss

If you need any advanced trouble shooting, let me know.

Thanks man. It worked perfecty!

glad i could help :)