Cannot use my Techin smart products with DDWRT Guest network acting as AP

I have an older Netgear R7000 with DDWRT that I have used as router and AP fine for a couple of years. Recently I got an Edgerouter X to handle the routing part instead, so the R7000 only acts as an AP. I did this by disabling the DHCP server entirely on the R7000. Both the 2.4Ghz and 5Ghz wifi works fine but at first I lost the internet on the guest network. After some searching I managed to get it working as well by enabling DNSMasq and adding these options to it:


My guest network is on interface wl0.1 and it can assign ip between

Now if I connect my phone to this guest network, everything is fine! But when I try to connect my smart sockets by Techin they cannot connect. When I try to pair them, they actually show up in my router as connected so I’m not sure whats going on.

When I contacted their support they just sent me a copy paste answer:

Check whether your device is powered on and turned on.

If you are informed that the device has been bound to another account during the binding process, please follow the instructions on the posted page to unbind the device and add it again.

Ensure that the network environment has strong and stable signals. Troubleshooting: Place your mobile phone or iPad connected to the same local area network close tothe device, and open a web page to check whether the browsing is smooth and stable.

If the network is normal but the device network connection still fails, check whether the router is overloaded. You can disable a device’s Wi-Fi feature to reserve the channel for resource reallocation.

Check whether the router password you entered is correct. Check for spaces before and after the Wi-Fi account or password and case sensitivity issues.

Ensure that broadcasting is enabled for Wi-Fi and is not hidden. Ensure that your device has been added over a Wi-Fi band of 2.4 GHz. (Check whether the 2.4 GHz band and 5GHz band share the same Wi-Fi account. If so, we recommend that you configure two accounts and switch to the 2.4 GHz band during network connection.)

Ensure that the encryption method and authentication type are set to WPA2-PSK and AES, respectively, for the router’s wireless settings, or both are set to Auto. Ensure that the wireless mode is not set to 11n only.

If wireless MAC address filtering is enabled for the router, remove your device from the router’s MAC address filtering list to ensure that it is allowed to connect to the network. You can also disable MAC address filtering.
Ensure that the DHCP service is enabled for the router. If not, the IP address will be occupied.

I have checked all of these though I’m not sure what they mean with the last bullet. My DHCP is enabled on my Edgerouter X not on my Access Point, and I mean, it seems to work fine for all of my other devices.

Anyone got experience with these units at all?

As an experiment I also set up a hotspot with one of my phones and then connected another phone and it could pair the smart plugs just fine. So I believe there is something wrong with my network.

So, my first recommendation is to convert them with Tasmota and then run Home Assistant or ESP Home or something. Get them out of the cloud.

To answer your question, these devices need access to the internet to run. When you first set them up using your phone, the devices are in AP mode. Once you configure them and they reboot, then they start phoning home. You cannot use them unless they have unrestricted access to the internet. That means that DNS must be enabled and they must be able to resolve all of their outbound connections. If you block anything or they do not have DNS resolution, they will not work past the initial setup.

If you want to isolate them from your network, put them in their own vlan.
It is also recommended to set these items up with a static IP so that they are easy to identify.

I have just converted all of my Tuya devices to Tasmota and I run Home Assistant on an Odroid N2. I may be able to assist and point you to some good references if you want to go down that route.

1 Like

Hi, cool, I didn’t think I would get any replies. :slight_smile:

So Tasmota seems interesting. You have any guidelines/tutorials on how to convert them? I guess I need to do something like this?

For my original question: I understand. I’m not sure what is blocking them though because the guest network works perfectly fine on my phone. Before I had my ERX my R7000 was also the router and I had the guest network bridged with Net Isolation on. My main reason for having the guest network is to isolate all IoT devices there, especially shady chinese stuff…

I am always facing trouble with the DDWRT documentation because it always seems to be outdated or contain invalid information. I currently use the setup described here:

Edit: So I turned on Force DNS redirection and it worked for like 5 minutes. Then it stopped working again… God I hate DDWRT sometimes. Just wasted 3 hours on it. Quite frankly I’m gonna throw it in the thrash as soon as ubiquity launches their AP’s with Wifi 6.

Edit2: So I took a backup of my settings(that didnt work) and then experimented and restored the backup and now it does work…
Buggy mess.

x2, tasmota is mind blowing. It even has syslog out so I have splunk checking it’s heartbeat/uptime and triggers.

Wait what? I have a unifi AP pro in my Amazon list…

1 Like

Sounds awesome. Yeah there is like no way to debug these devices, no logs, nothing. Impossible to know what is wrong. Seems like a cool thing, I might dwelve in on it some day. I also have a Raspberry pi lying around, Maybe I can host the assistant on that?

Yeah, their AP’s with WIFI 6 are coming like any day now.

1 Like

They make a build for the Pi- I think you want a Pi3, not sure though.

Works on the Pi4 now and that is what they recommend, but it is 32 bit. You can also set it up from scratch, but if you are not GNU/Linux savvy, then use their pre-built images

As far as guides, I recommend looking up digiblur’s Youtube Videos. He has a playlist on setting that up. If you join the discord, there is a gaggle of us that hang out there. It is divided into different rooms like tuya convert, tasmito, esphome, home assistant, and etc.

1 Like

Dnsmasq on dd-wrt behaves strangely, I can’t connect some devices to it if it’s enabled. I’m willing to bet that’s your problem, too.

That sounds like a pretty straightforward set up: Edgerouter to the R7000 via WAN port, fixed IP. Standard AP configuration.

Better yet, install OpenWRT, it’s miles ahead.

1 Like

Alright, I only have a RP2 so maybe I will get the newer one. I’m not good enough dabbling with Linux :smiley:

Is it better? I’m really just looking for the most stable software.

There are experimental images fro RPi1 and RPi2. If you want to run some other things like an MQTT server and some additional addon to any smart speakers and the like, then you will want a RPi3 at least.

Looking at my Odroid, with the other addons (about 6) I am coming in at just under 2GiB so even a Pi4 wiht 4GiB RAM (I think55USD before shipping) would be a good purchase unless you can get the Pi3 for a steal. You can also utilize an old laptop or something just for testing.

None the less, you really want to take your stuff out of the cloud because most of this stuff is made by Chinese firms. Not trying to be Xenophobic or Inflammatory, but seeing as what is happening in Hong Kong, you cannot really trust the CCP at this point. You would not want them snooping on your network or turning your smart devices into drones for a botnet.

Alright, cool, I might look into that then. :slight_smile:

Yep, I am aware and a little bit concerned by the fact that they are Chinese. I’m still new to “smart” things and IoT. If I do convert these outlets to run Tasmota, I do have to have an controller right? So everything will effectivley just be local and nothing goes to the internet? I actually dont need any of the smart features per se. I only use them as timers, letting lights turn on at sunset and off after a couple of hours. So what I’m basically asking is, do I need an active controller for this or can Tasmota handlet his on its own? Because I would probably just set this up once and then be done with it.

Ah screw it, I’m gonna try to convert one of my sockets, see If I can get it working. However I’m note sure about the instructions:

I have fired up Ubuntu in a VM on a laptop and I have a spare phone at the ready. I have cloned the repo and installed the dependencies. The first step: “Place your binary file in the /files/ directory or use one of the included firmware images.” What binary file should I use? They include some:

They say to use tasmota-wifiman.bin but I cannot seem to find it? If I look at Tasmota repo, I cannot find it.

The sockets I have are these:

Off topic: Would have been cool if they ever released the Home assistant server as an app for android. Seeing that I already have old phones lying around, an Nvidia Shield etc, would be aweosome to just be able to use any of those. :slight_smile:

Home Assistant does have an App, but it phones home to your home assistant server (controller as you called it). You could run it on your phone with a docker image but I have not done that before.

In regards to tasmota, yeah, you do not need home assistant to do the timer functions, that is baked into the images. You can pull the images from here,
Start with the " tasmota-minimal.bin" to get the device up and running. Then copy and paste the template in the the add modules section of the self hosted page. Then you can upgrade with the OTA feature. IT usually defaults to " tasmota.bin.gz" which has everything that you will need for that plug.

The wifiman image will allow you to set the access point information when you flash the device, but I find it fiddly sometimes so I just do the manual flash with the minimal image, put in my template and wifi information, and then OTA the upgrade. If you have issues, come check us out in the Tuya-Convert or Tasmota section.

PS. I hope you do not have the version that has the RealTek Wifi Chip. That is currently not supported because RealTek does not provice open source drivers.

Oh, and make sure that what ever tool you use to flash, back up the original firmware first just in case you are not happy with Tasmota. You can reflash back to stock Frimware and enjoy the plug the way the manufacture advertised their product.

1 Like

Aha, I see. I don’t know what chip my plugs have and they are not especially easy to open.

I have tried the flashing proceedure now from Ubuntu in Virtual Box. It can open all the ports and setup the AP. Then when I reach the part were I am supposed to put the plug in pairing mode and press enter, the entire terminal ju freezes up. Tried couple of times now, same issue everytime. Maybe I try it from my RP2 instead so its not virtualized`?

Did you pass the wifi device through to the VM? You need to attache a wireless device or dongle to the Linux VM. You could boot into a live distro and o it that way as well. I actually used my Pi 1 to do the tuya-convert/tasmota flashing before the mosfet finally gave up the ghost a few weeks ago.

Yep, I have an external USB wifi adapter I use. So in the VM I can see my AP and connect to it, no problem.

Interesting. I have never had this issue. I have not watch this video for smart plugs (I have none) but Travis is who got me started down the uya-Convert and Tasmota/Tasmotizer route.

Basically, your Wifi dongle will host the wireless AP for the plug to connect to. I also use to tuya convert.

Yeah, at 8:09 in that video, the terminal just freezes.

I will try from my RP2 instead, just have to flash raspian on it.

Yeah, good luck with that then. Never had this issue. I have had some 3way switches that could not be flashed due to new encrypted firmware (I use predominantly Treatlife) and had to open them up an solder.

Ok, yeah this happens before I even connect the plug so there is either an issue with the python program or my Vm setup is wonky somehow.