Cannot update RX 6700 XT drivers on Windows 10

This has been bothering me for a while. So much that I reinstalled my Windows 10 gaming install.

This is what I have:

  • X470 motherboard with an R7 2700X
  • XFX Radeon RX 6700XT
  • works fine with AMD driver 21.10.2
  • works fine on Linux 5.16 + Mesa 22.0

I try to:

  • update to or do a clean install od any release from November 2021 or later

What I get:

  • a bootloop where I see the motherboard logo with the hotkeys, blackscreen, motherboard logo with hotkeys, blackscreen, motherboard logo, automatic startup repair
  • automatic repair results in a bootloop
  • only certain safemodes worked
  • restoring a restore points let’s me boot to Windows again

I tried:

  • reinstalling Windows 10 Pro 21H2
  • disabling overclocks and XMP profiles in the UEFI
  • running sfc and dism
  • either upgrading or the clean install option
  • use the Bug Report Tool lmao

Any ideas?

It’s a windows update problem, it’s giving you a specific bad driver that has poisoned windows update for like 2 years now


So when the Radeon Installer installs the driver and cold reboots during installation, it’s a Windows Update problem?

1 Like

Win update give a bad driver for the chipset I think and that messes with something so when the card has a driver it messes with things

Try turning off update and cutting the network connection install chipset driver downloaded to a flash drive, then installing GPU driver


I agree with @GigaBusterEXE that it’s likely a driver from Windows Update that’s hosing your system. To confirm do a system restore and leave it idle without internet for whatever period of time would confirm Windows Update is the culprit.

Then start by blacklisting the driver you suspect using group policy.


Win11 was especially heinous about this, you’d get the heated win11 optimized drivers and then update would give old crappy ones, was a pain when benching early win11


Before I try another reinstall when I can be bothered I took the hint and downloaded the latest X470 chipset driver from AMDs website as it was recently updated. Sadly no luck either.
Still the same behaviour :frowning: .

Hey here is another update.
I did a fresh Windows 11 Pro installation and kept it fresh by not installing ANY software at all. I let it install updates and reboot many times.

I downloaded the latest recommended driver 22.3.1 and got the same behaviour yet again. Boot loops and automatic recovery!

And I found this out on Windows 10 as well, the latest driver that I can install is 21.11.3. So there is a breaking change in 21.12.1…

I have no idea what to do apart from annoying support to forward me to L2 or L3 support.

1 Like

Support sucks. They gave up and just told me to stay on the old version and just wait for the next update. Riight, unless they know anything specific it won’t be fixed.

1 Like

Finally I figured out the issue.

It is my secondary display that is causing issues. It is an old Samsung monitor that I connect to my GPU using a DVI to HDMI cable. With it disconnected I was able to update my drivers.
When I plug it in, it causes a bluescreen that reads “ATTEMPTED_EXECUTE_OF_NOEXECUTE_MEMORY” What fail “amdkmdag.sys”.

So yeah… AMD GPU driver update 21.12.1 for Windows 10/11 broke my monitor lol. Again this is not a hardware issue. The monitor is fine and dandy on older driver versions and Linux.
Well I’m glad that I scored a “homeoffice” monitor at work that was supposed to be thrown away. That’s gonna be my new second monitor :wink:

I used the AMD Bug report tool but have no idea if my report will be ignored. I added an email too for if they care.

Well and this is the final answer from support:

Thank you for sharing your findings.

I am glad to see that you could install the AMD Software: Adrenalin Edition 22.4.1 on your system with the secondary monitor (Samsung SyncMaster P2250) disconnected.

Since your Samsung SyncMaster P2250 monitor is from 2009, it may not work as expected with the modern hardware and drivers as such old monitors are not tested.

At this point I would suggest the following.

Use the known working drivers.

Use a modern secondary monitor.

I appreciate your understanding in this regard.


Wow, that response infuriates me! I’d ask if this bug is being forwarded to development for further investigation or if your ticket is being closed due to unsupported hardware. If it’s the latter I’d be curious to know how they define a “modern monitor”. Does that mean less than 10 years old? 5 years? :thinking:

They just didnt want to deal with me. A previous suggestion was to just not update my driver cause it works. I think it’s just support being glad to finally close the ticket and never having to hear from me again.

Well guess what, UE5 does not just work with a six month old driver.

1 Like


Had to make an account after getting terrible deja vu from your thread. I want to confirm that I’m experiencing an identical problem to yours!

I didn’t even catch on to the second monitor until I read it here and tried it for myself. Windows 11 boots no problem without my second 4:3 VGA monitor present.

The latest recommended driver version 22.5.1 is still giving me grief. I might just take them up on their advice and try another monitor.

1 Like

Yeah. They just made a bug and did a “wontfix”…