Return to Level1Techs.com

Cannot install "Service Pack 1 Platform Update"

helpdesk
#1

Hello, Level1Tech Gurus :smiley: Planetside 2’s Test server got a Dx11 update. In order to even start the Test Server game, I get an Error listed in header needing KB2670838 which is the Platform update. No matter what I try I can’t seem to install it.

Steps I tried from DuckGo’n other than different ways of installing KBx838: Repaired Win update. Deleted Software Distribution. SFC /Scannow. =all steps were followed. I’m condensing.

The last thing I tried was extracting the files from the KBxx838 file. Which is 2 CAB files, a .txt and a .xml. When I try to Install the bigger cab file, it fails. BUT it’s the first time I even tried at installing a CAB. Which the guide I followed was using an elevated cmd prompt, from Microsoft btw.

Win7Pro.x64 - MSI.z77a-gd65 - i5.3570k - w/ R7770. I have the update for hybrid systems even tho my GPU ain’t listed as a suspect :stuck_out_tongue:

Anyways if I don’t find a solution I’m just going to do a fresh install. Thought win10? but I don’t think so xD lol Maybe 8.1? idn.
So if Y’all have some insight, that’d be great. Otherwise, Thank You for reading :slight_smile:

0 Likes

#2

Update: I found an answer to other problems I’ve been having and it has to do with KB4493472. Other people posted about it and by me removing it I was able to cure other problems I was having. But I still can’t install the platform update. No biggie. I may start a thread asking which OS to go with. so…

If any mods see this Please Lock / Delete this thread. Thank you :slight_smile:

3 Likes

closed #3

Closing at request of OP.

0 Likes