Return to Level1Techs.com

Cannot configure libvirt to use qemu/EFI

Hello-
I hate asking for tech support on this stuff, but I’ve RTFM-d every resource I could find, and have gotten nowhere. Also I apologize if I’ve confused any names like libvirt, qemu, etc.

I am running Arch Linux, and trying to do the (in)famous gpu passthrough VM setup. I am following this guide on the glorious Arch wiki “PCI Passthrough via OVMF” (can’t post a link as a new user)
Everything has gone fine until section 4.1, configuring libvirt. It instructs me to edit a config file to enable EFI support with the virtual machine, but when I edit it as instructed, and restart libvirt, it prevents virt-manager from making any kvm connections. (Specifically it says Error: No active connection to install on.)

Nearly every resource I found told me to add the same line to the nvram section, so I have no idea what I am supposed to do instead.
The comments in the config file mention that the nvram option is obsolete, so I am wondering if the guides (including the Arch wiki) are just all outdated.

I’ve been searching for a solution for a while, and have only found the same info.

Thanks for any help!

What an odd distro that it’s not setup for you more or less automatically.

I recently Did a fresh install of fedora few weeks back, installed the @virtualization group and UEFI was just there, and I think the default.

Are you running the GUI as root? Is your user a member of all the requisite system groups?

1 Like

Something that is not mentioned in that article is the fact that libvirtd needs additional packages for the virtual network. If libvirtd isn’t starting try installing the following packages: dmidecode, dnmasq, and ebtables see if libvirtd starts then.

Reference: https://bbs.archlinux.org/viewtopic.php?id=236621

Also, as gordonthree mentioned, make sure your user account is in the right group, I personally have my user in the kvm group for virtualization and it works for me. These are the settings I would use in /etc/libvirt/qemu.conf:

user = “your username here”

group = “kvm”

Hope this helps, good luck!

1 Like

FFS I not only made a syntax error in the config file, but I forgot to uncomment a line too!
…Everything works now, I was stupid.
Sorry about that.
Last time I make a forum post at 11pm…
Thanks for the help, sorry if I wasted your time.

1 Like