Cannot build wireless driver in Fedora

I am trying to install this driver on Fedora 21: http://www.broadcom.com/support/802.11/linux_sta.php I have kernel-devel and when I run "make" I get this error: "Neither CFG80211 nor WirelessExtension is enabled in kernel" I'm not sure what I need to install the driver.

Edit: I am now getting a new error (couldn't get code tags to work so I just took a picture, you can still see the important parts:


It's a known issue, but you definitely do NOT need to make the driver, it will compile a binary blob into your kernel, which is being blocked by SELinux, probably not without reason. It would work if you would disable SELinux, but that's simply not necessary, because....

The kernel update of today solves the issue.

Delete the Broadcom crap you've downloaded (and NEVER EVER download any driver from a website again lol!), and do a su -c 'yum update'.

It will upgrade the kernel 3.17.4 from build 200 to build 300, and the Broadcom WL will just work.

 

Edit: come to think of it, you also need the Broadcom fwcutter package if you have a B43 chip, and I don't know if you've tried to install the broadcom packages from the Fedora repo before. If you have, you'll also want to uninstall the wifi kernel modules and reinstall them after updating your kernel (those would be the packages broadcom-wl and akmod-wl). Don't forget to reboot after uninstalling, so that the old kernel modules are not in the kernel any more when you update the kernel. Reinstall the kernel modules for broadcom wifi afterwards (and again, don't forget the fwcutter if you have a 43 series chip).

[[email protected] ~]$ uname -a


Linux fedora 3.17.4-302.fc21.x86_64 #1 SMP Thu Dec 4 19:12:43 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

By default it tries to use the b43 driver.

cf. my edit lol

b43-fwcutter or bcm43xx-fwcutter? They have the same description...

Also what Broadcom package from the Fedora repo were you talking about? I also can't find broadcom-wl or akmod-wl

probably just b43-fwcutter lol, but I think it's going to be the same thing, maybe the one for 32 bit and the other for 64 bit?

Fc21 is still fresh, and there are quite a few bugs that need ironing out. The biggest bug, one that REALLY pissed me off, was that python didn't compile properly, but they seem to have fixed that today with a full python update. By next week, most bugs will probably have been patched. It's kinda sad that Fedora has had these release bugs for a few releases in a row now, but they're extremely quick to patch.

Then you don't have them, and you don't need to uninstall them, which is good.

Does your wifi then work with wfcutter installed after a restart?

b43-fwcutter was already installed and nothing changed after a restart.

With bcm43xx-fwcutter nothing changed either after a restart.

check your debug messages to find out what's going wrong (dmesg).

This can be two things:

1. Using the installer provided by Broadcom messed up stuff (very well possible, even if I would expect SELinux to block it, but maybe you were set to permissive or disabled, so check the status of SELinux to make sure);

2. You have system with Secure Boot. I'm not really sure about this, but I suspect that the wifi functionality might be loaded in UEFI fastboot is your system has that, and I suspect that the hacked broadcom drivers (because that's what they are, it's a hack to avoid binary blobs and still make those chips work) may not be signed, and therefore maybe blocked by Secure Boot. If that's the case, maybe disable fastboot and see if it still happens.

I've never had a broadcom wifi, so I don't know what to expect exactly. I know it's a real drag though, there's a lot of problems with it. You do have a 43 series Broadcom chip on your system, right?

I know before when I ran Gentoo on this laptop I had to compile the kernel without the ssb thing. You know if it would effect anything?

That is a possibility also, but I though that WOL bug had been fixed to be honest, but you don't need to recompile the kernel for that, you can simply blacklist ssb kernel modules, and maybe also blacklist the b43 modules.

To do that, press e in grub, and add rd.blacklist=<kernel module name> to the last long line (probably the second last line of all) for every kernel module you want to blacklist.

I think this might be my problem:

[   17.780297] b43 ssb0:0: Direct firmware load for b43/ucode16_mimo.fw failed with error -2
[   17.780318] b43 ssb0:0: Direct firmware load for b43/ucode16_mimo.fw failed with error -2
[   17.782464] b43 ssb0:0: Direct firmware load for b43-open/ucode16_mimo.fw failed with error -2
[   17.782482] b43 ssb0:0: Direct firmware load for b43-open/ucode16_mimo.fw failed with error -2
[   17.782485] b43-phy0 ERROR: Firmware file "b43/ucode16_mimo.fw" not found
[   17.782488] b43-phy0 ERROR: Firmware file "b43-open/ucode16_mimo.fw" not found
[   17.782490] b43-phy0 ERROR: You must go to http://wireless.kernel.org/en/users/Drivers/b43#devicefirmware and download the correct firmware for this driver version. Please carefully read all instructions on this website.

Yes this is an older laptop with a bcm4322. I don't think it has fastboot or secure boot, let alone UEFI.

yup!

do you know exactly what broadcom chip your system has?

(lspci to find out)

Yup bcm4322. Followed the instructions here: http://wireless.kernel.org/en/users/Drivers/b43#other_distros

Everything is working now! Now need to figure out how to get LAN working...

lan might just be disabled by default. For some reason, it was disabled by default on my Fc21 WS install and I had to connect it manually at first...

this is why I don't linutz.

I can see an interface for lan but when I plug in a cable it reports it as unplugged. Its state is set to DOWN but when I run "sudo ip link set enp3s0 up" I get "RTNETLINK answers: Cannot assign requested address"

It's a Realtek RTL8101E/RTL8102E using the r8169 module. I think when you go it Realtek's download page it lists it as using the r8168 module. 

Well it was just a missing firmware issue. But ya it's pretty annoying.