Can`t access Bios

Hi there,

I have a Gigabyte Z87-HD3 motherboard, but can`t seem to get into the bios. I`ve mashed every possible button and even tried the built in option on windows 8.1(64-bit). But nothing short of disconnecting my boot drive seems to work. Anyone got an idea?

thanks :)

probably fast boot option enabled in the bios.

as soon as you hit the computers power button, just keep hammering the Del key. this should get you into the bios.

I`ve just double checked, but the fast boot option is disabled. And hammering away doesn`t seem to work.

Try using another keyboard to see if your current keyboard is starting to go bad or the USB port my be going bad.  You can also try using a different USB port to plug your current keyboard in to.  Another thing to check is if your current keyboard you are using is USB 2.0 or USB 3.0.  I was using a keyboard once with an F1 key not always working.  I thought there was something wrong with the computer, but it was the keyboard.

Hope this helps.

I've been fiddling around with about all the settings I could find in the 'BIOS features' tab and found that if I enabled 'Onboard LAN Boot option control', mashing the delete button seems to work. The 'UEFI Firmware settings' option in Windows 8.1 also works now.  No idea why that did it though.

i would advice to update the bios, Gigabyte early bioses had some issues.

Also check in your bios options if fullscreen logo is enabled,

if so? then disable this.

Make sure that the 'Fast boot option' is disabled in windows too. So if i were you this is what I'd do, update BIOS first and foremost. Second, Make sure fast boot is turned off in BIOS. Third, under power management in the advanced tab, make sure that the fast boot in windows is disabled as well. Note that if you've shut it off in BIOS it should be disabled as well, but double checking never hurt. Good luck.