Can someone please help me out? (apache,PF,IPs)

I'm trying to make an owncloud server using apache in win7. Im new to servers and networking but Ive done a blind stab at it.

Heres what I've done:

- dowloaded xampp and put owncloud on the apache server.

-port forwarded port 80, but the router told me it was in use(netstat told me otherwise) and that webserver port was moved to port 8080. So I forwarded port 8080.

- I made "holes" in the firewall for port 8080

- I made changes in the httpd.conf:

1# Listen: Allows you to bind Apache to specific IP addresses and/or

2# ports, instead of the default. See also the <VirtualHost>

3# directive.


5# Change this to Listen on specific IP addresses as shown below to

6# prevent Apache from glomming onto all bound IP addresses.





11# ServerName gives the name and port that the server uses to identify itself.

12# This can often be determined automatically, but we recommend you specify

13# it explicitly to prevent problems during startup.


15# If your host doesn't have a registered DNS name, enter its IP address here.


17 ServerName (my external IP):8080

(server answers to and my PF settings)

The problem is that if i input my external IP in my browser the router answers, I seem to recall that that didn't happen before i did the port foward. (for the record I've tried many different combinations of port and IPs in PF but nothing seems to work, I've tried to PF to my NICs address and but no use)

If i input (external IP):8080 I get no response.

I ran PortChecker It says port 8080 is unreachable. But I've tried so many possibilities for PF don't know what to do any more.

I figured I'd be able to input (my external IP):8080 in the browser and my server would  answer, am I horribly mistaken?

As you can tell I'm pretty clueless, I'm learning as i go, but now I'm stuck. Can someone please point me in the right direction?

You have to Port Forward to your computers Internal IP Address;

E.g. -> Ports 8080 TCP & UDP

Then when you attempt to connect to your external ip address [ ] you'll probably get something like this message:

That's assuming that your ISP isn't blocking anything.

Next, you need to find the file: httpd-xampp.conf

You should find something like this in there:

  1. #
  2. # New XAMPP security concept
  3. #
  4. <LocationMatch "^/(?i:(?:xampp|security|licenses|phpmyadmin|webalizer|server-status|server-info))">
  5. Order deny,allow
  6. Deny from all
  7. Allow from ::1 \
  8. ::1 \
  9. fc00::/7 \
  10. fe80::/10

 Where it says line 8, add your own (external) IP address to there. 

Edit - You will probably need to restart Apache after saving the changes to the .conf file.

Thank you for your quick reply.

so is not my internal IP?

is it the 10.0.0.X  which is found in ipconfig, called IPv4?


the strange thing is that if i enter i get the "http error 403".

my httpd-xampp.conf doesn't contain line 8. Can I just add it ?

This is where you can view your computers Internal IP Address: - Don't be suprised if yours is different, as it may well be that 10.0.0.x (or 2 it seems to be in your case) should be the location of the Apache server.

Yes, add the extra line exactly like I've shown in the previous post, except for your external IP address so it looks like;

Thank you so much DarkWolf, finally some progress.

I've inserted line 8 and restarted apache.

These are my router settings(their terminology is a little strange)


The fault are still the same:

xx.xx.xx.xx - router answers

xx.xx.xx.xx:8080 - nothing is my internal ip

I tried to change httpd.conf :


*ran PFPortChecker as I was writing. It says port 8080 is OPEN, but could someone help me make sense of that note?


Just do the Port Forwarding to your computer; So has Port 8080 TCP & UDP.

Make sure that you change the >> httpd-xampp.conf << file so that it has that "line 8" in it.

Open >>httpd.conf<< back up and you should only change the ports - so it should be:

  • Listen
  • #Listen [::]:8080
  • #Listen 8080

Thank you. Finally some progress, I've been stuck at this problem for days.

I deleted the unnecessary PF. Now PFPortChecker says all is fine.

i changed httpd.conf as you said. Now I can access my server from all the loopback addresses (127.x.x.x).

but my external IP xx.xx.xx.xx:8080 still returns nothing.

Maybe I have to test it from the outside?

Yes, try it from an outside source. If it returns nothing, then it could well be your router or ISP that's still blocking something. If the computer outside of your network manages to connect, or pulls a 403 error then you know that it's just that you can't loop outside your network and back in again.

Thanks alot.  I'll check it from work tomorrow.

Hmm.. I think one of my neighbors is still using WEP on their wireless.....  Never mind :)

If this works I'll try to tackle the whole SSL stuff. I want to run https.