Can a brother get some help?

Hey, I've recently had dome trouble with Steam. I barely got into gaming and I am not very tech savvy. I bought Skyrim and Metro 2033 and others off of steam. Now all of my other games work, Hitman: Absolution, Tomb Raider: Anniversay, Vindictus. At high settings they work fine. Now Metro 2033 starts to load for a second and then pops up a DDl file error. It goes something like this:

C:\windows\system32\x3daudio1_7.dll is either not designed to run
on Windows or it contains an error. Try installing the program again using the original installation media or contact your system administrator or the software vendor for support. Error status 0xc000012f
I've tried everything I can think of/read. I unistalled the game, twice. I Updated all my drivers, used Windows update and updated Direct X. I am tired of downloading files as I am pretty sure I am on a 500GB internet plan. I don't want to go over as the last time I did I got a warning about some bullshit 50 dollar fee if I do it again. Please can I get a few more tips on what to try? I don't want to go it alone as I do not want to break my new computer. My profile has my specs if that matters here. Also Skyrim isn't working. I have yet to download it again because of the capped data plan but do you guys think that will work? I star the game, it goes to the menu and when I click to start the game nothing happens. Weird. I went into Steam and verified my files it said one had to be replaced but I got the same results, the game goes to the menu and then disappeares. So yeah I don't know what I'm going to do about those games. I had Metro 2033 running a few weeks ago before I upgraded to Windows 8 Pro and everything was golden. Also Dues Ex: Human Revolution plays perfectly.
Yeah please help. Those games are really fun and I already payed. I just seem to have come to the end of my limited tech knowledge. Thank you in advance for your efforts. :D

try compatibility mode for win7 sp1

For the Steam program?

It would be better to try it with the actual game. I'm assuming steam is installed on your hard drive rather than your ssd, so go here:


It's there where you will find all of your installed steam games. There is an executable file in each one that will start the game. For Skyrim, there will be a file named "SkyrimLauncher." Right click on it and go to properties. There will be tabs at the top, and one of them will be named "compatibility."

Click on that tab, and you will see a check box labeled "Run this program in compatibility mode for:"

Click on the check box and it will open up a drop down menu where you can select your compatibility mode. Select "Windows 7 (Service Pack 1)" in the drop down menu. Then click "Apply" and "OK."

The same process can be used for Metro 2033....actually, I take that back. For some reason Metro 2033's program files are highly elusive on my computer. The only thing that shows up under the Metro 2033 folder is a text document, and I can't seem to find the executable anywhere even though the game is installed and works fine. I'm sitting here scratching my head, so if anyone could lend any insight, that would be greatly appreciated.

This is a problem with being an early adopter of Windows 8 unfortunately. Not everything is going to work for you until the first service pack comes out (probably). That's why I'm sticking with Windows 7...well...that and there's no reason for me to be switching to 8 right now. If Direct X 12 decides to come out of the shadows, then I might feel a little more compelled to get it, although I'd have to replace my graphics cards too if that were to happen.

I'm pretty sure my Metro was in steamapps/common when I had it installed, weird.  I know it's a silly question, but you did reboot after installing all the updates, right?  x3daudio is a directx thing.  If that's missing, it's a problem with directx, though I have less than no experience with Windows 8 right now.  I really should install it in another partition just for the experience.

Try using the option to  "verify local content" to make sure all the files that downloaded/installed correctly. I had some odd issues with Metro2033 that were only solved after doing that then the game downloaded fixed itself.

I have done that for both games and they bothhave problems and it says it fixes them but the same problem persist.

Thank you so much for the detailed response. but sadly I couldn't get either game to load. I have also deleted and reinstalled both games since I posted this. I was hoping third time would be the charm. Nope. :/ I'll just wait and see if an update eventually fixes this I guess. I may pirate both games to see if those versions will work. I haven't pirated games before but since I already bought both I think it's ok. I'll have my friend help me. 

I actually have the same exact problem as you. Opening Geforce experience freezes up when opening too. I also can't successfully install many games such as Metro. Did you find a way to solve this?

My next step is to reinstall my nvidea drivers/geforce experience entirely.

I'm on a x58 mobo platform with i7 980, nvidea 680 gpu, 1200W power supply, 12GB RAM, steam installed on boot drive, updated OS, and drivers.