Built my own comp need some help

I recently built my new Pc. Everything was fine and working for about two days. I was playing some games then got off and went to the store. When I came back I tried to "wake" my comp up but it would not, the CPU, GPU, Case fans; and case lights were still running. But I had to signal to the montior. After trying a couple of options I found that none of my peripherals (wireless mouse and keyboard) were working either.

Steps taken:

Double checked that all connections from PSU to Mobo were in fact connected and in thier approriate locations.

Made sure there were no wires interefering with operations.

Double checked optical cables to ensure they were working properly.

Reseated CPU and made sure there was not an excess of thermal paste.

Reseated RAM units.

Reseated GPU. 

Checked capacitors on MOBO. 

Installed new CPU AMD FX 8320.

Installed new GPU MSI TwinFrozr 7850.

Installed new CPU after finding out I may need to update BIOS to a more current version to support the FX series. AMD A4-3400.

Took out and reinserted CMOS battery.

Slammed head on desk repeatedly for 5 minutes... 


System Specs: /Denotes variants tried to facilitate a sucessful boot.

CPU: AMD FX-8350/ AMD FX-8320 / AMD A4-3400

MOBO: ASrock Extreme 3  

RAM: G.XKill Ripjaws X DDR3-1600 (x2-8gb)

PSU: NZXT- Hale82N 650W semi-modular.

GPU: Sapphire Radeon HD7870 Ghz / MSI Twin Frozr Radeon HD7850

OPD: Lite-on DVD/RW

Storage: 128GB Sandisk UltraPlus SSD, Seagate Barracuda 1TB 7200 HDD  


You should try to see if you can get a display out of your motherboard. To make sure that its your GPU and not the rest of your system.

did you seated the cpu correct?

I had no problems with the cpu. It went as easy as it goes. I ran a stress test prior to installing steam. 

My mobo does not have integrated graphics. 

look if everything is still connected, like the cpu power connector.

try to reseat the memory. try to reseat the gpu.

if it still not works, try to reset the bios. by disconneting power and take out the battery.

I tried reseating the memory and GPU previuosly, but went ahead and did it again. I tried to reset the BIOS, but still nothing. I'm pretty sure as of now it is the CPU so I went ahead and contacted AMD, but have not gotten a response. Do you think it would be anything other than the CPU? If it'd something like the memory how can I test it without having a working computer to put it in? 

Is the PSU turned on?

Yes, yes it was: or at least I hope it was since the lights and fans were working, if not my comp may be possessed. Do you know of any good Computer  Exorcists?

What cpu and motherboard do you have?

I have an ASrock Extreme 3 with an Fx-8350, also have tried an FX-8320 from one of my other comps, and an A8-3400. When I first got my parts I had a faulty PSU so now I have a NZXT Hale82N. I have tried 2 different GPUs The origional being a Sapphire 7870 Ghz ed. and a MSI 7850. I have tried rebooting with only one ram stick in the recommended slot. I have made sure that everything is seated properly. I'm just all out of ideas. 


I have the asrock99fx extreme 3 some of the lower end mobo have a cool boot bug where if the pc whent to sleep it whont start back up or if you powerd down the computer and left if off for 2/3 hrs it whont boot back up you have to keep powering up the computer serveral times before it will boot.

In my case with the asrock mobo i had to change my bios to a older bios to fix the problem.

I had to revert to Version P1.20 bios (and i tryed them all) but i dont think your cpu is supported in 1.2 bios as its a older one.

This cold boot bug happens with the lower end asus mobos to.

This only seams to happen with FX chips on these as when i droped a amd phenom on the mobo it worked fine with any vershon of the bios

Hmmmm interesting. Thanks for the response. So what you are saying is I should get either a Phenom or a new Mobo? I'd rather not have to try and reboot all the time it's very infuriating. 

Try out differnt vershons of the bios (download the bios from asrock unzip it and put it on a usb stick)

When your in the bios go to easyflash and the mobo will update*dont use a bios thats too old for the cpu if you do it will not boot at all*

Make shure your computer dosent power down wile changing the bios as this will brick the motherboard.

If thay dont help look at the Gigabyte GA-990FXA-UD3 or the Asus M5A99X EVO R2.0 for around $100

Try going old School first, take everything off the board except the CPU and see if it you get  post POST looking at pictures of your board it does not have an onboard speaker so you are going to have to plug one in, they are ususally included in the box or with your case. Look in your manual on where to plug in the board speaker its usually around the frnt panel connectors. Once you have accomplished this you are ready for the beep counting process. In short no beep at all means dud board one beep means your problem lies elsewere

Good luck

Thanks I'll probably get a new mobo. I figure I can reuse this one in a build I was going to do for a friend, his b-day is coming up. I was going to go with a fx-6300 but a Phenom will be ok. Seriously I cannot express my gratitude enough I have been banging my head around trying to figure out what was wrong.

Re-install all drivers - chipset, gpu (run driver sweeper as well beforehand), network etc.

Go through all the power options in windows. Make sure you disable the option that turns off usb devices.

Also a little more chipset voltage can help.

Best of luck.

Thanks, I found the problem out thanks to a guy who had the same problem. Thanks for the Beep code that'll probably come in handy later.