Built first PC having issues

I built a new computer about two months ago. It was my first build and it worked fine up until yesterday. I was on my computer and it blue screened, said something about USB issues. It turned off and I attempted to turn it back on but it got to the press delete to enter bios screen and froze. I unplugged everything except the monitor and tried turning it back on and the same thing happened. I have an Asus Sabertooth 990fx R2.0 and the boot device light was on so I turned off my computer and unplugged my boot drive. After turning it back on it went past the bios screen but stayed on a black screen with a flashing cursor in the top left of the screen. I then tried using the CMOS jumper as I heard that it would help but it didn’t do anything. I heard that it could be a PSU problem so I tried a different PSU but the same thing occurs. I’m not sure if this is the right place to post this but I really need some help. My computer specs are:

Motherboard: Asus Sabertooth 990fx R2.0

CPU: AMD FX-8350 Black Edition

GPU: Gigabyte HD 7870

PSU: Thermaltake SMART M850W

RAM: Mushkin Redline 16GB (2x 8gb Sticks)

SSD: Kingston HyperX 120GB (boot device)

HDD: Seagate Barracuda 2TB


Any help that you could give would be great. Thanks.

if he passed the bios post, but dont get into loading windows it should be something with youre boot drive.

try to look if  the boot drive is connected correctly. and also check your boot device priority settings..the ssd should probably  setto first boot device.

I forgot to mention that I cannot access the BIOS. The boot drive is connected correctly however and it was set to the the first boot device.

Check the boot device priority like MisteryAngel said just to make sure everything is set properly. If you still have issues, then it sounds like it might be the motherboard just because you said it blue screened because of USB issues.

Wait....why can't you access the bios?

hmm okay so you dont get a bios post,  thats wiered, try to reset the bios by taking the battery out, if it all doesnt work, im affraid something with the mobo is wrong, try to reseat the memory sticks, try to reseat the gpu, check all power cable stuff.


Ok. So I first took out the battery, put it back in, started my system up and the screen stayed on the press delete to enter UEFI BIOS even if I didn't have my boot drive plugged in, previously it went to a black screen with a flashing cursor if boot drive was unplugged. Then I tried reseating the ram and gpu and I checked the cables. After restarting my system it went to the black screen while my boot drive was plugged in.


okay so it shows on display press delete to enter bios wenn you do that you getting black screen?

not quite. My keyboard doesn't respond to any inputs, it just goes to black screen automatically. I don't think my keyboard is actually turning on as no lights come on.

do you have a legacy keyboard laying arround? (ps2) connect that and look if you can get into bios.

but i´m affraid you have to rma the motherboard

Yeah, it sounds like a busted motherboard. I don't know who told you that you needed a new PSU or why, because everything here points to the motherboard.

I actually did have one laying around, however pressing delete on startup just takes me to the black screen

I guess I'll just RMA the motherboard then. Thanks for the help.


yes rma the motherboard, looks like a bricked bios or something. or the board is complete failed. you probably get a new one ☺