Return to

Build-latest & keyboard/mouse sharing questions

So I got Looking Glass (b1) up and working on my primary workstation. Yay!

First, it’s got great potential, everything I hoped for. But there were/are a few rough-spots (mouse tracking & input device sharing). Because the trello & change logs indicate these issues have been addressed since b1 I decided to try building latest from github. Everything built fine but when I run the client it errors with:

./looking-glass-client: error while loading shared libraries: cannot open shared object file: No such file or directory

It appears to be some deep linker / packaging / tool-chain voodoo. Any insight on what’s causing this? I’m on Ubuntu 19.10.

Second, when I installed Looking Glass I had 2nd keyboard & mouse set as USB devices in the vm and everything worked great - the VM-captured devices worked and also the host keyboard & mouse worked via spice (mouse not as well). I decided to remove the 2nd keyboard so I shut down the vm, unplugged the kb & restarted the vm. virt-manager immediately errored with references not only to the removed keyboard (which made sense) but the mouse as well (which didnt). I had to remove the devices from the config to get the vm to start and once booted & ‘glassed’, the shared keyboard & mouse no longer worked. I shut it down, re-connected the 2nd keyboard, re-added the devices to the vm & booted but now although the devices are captured the host keyboard sharing no longer work. Which is the primary way I hoped to use the Looking Glass client on the desktop.

I’ve tried various add/remove device attempts to get things working again but to no avail. Is there some sequence to removing & re-adding the relevant devices or something I’m missing?

I do have a backup prior to the keyboard/mouse snafu, but I haven’t tested system restore… yet… hoping to find an alternative for a likely quick 1-line fix?..

Any suggestions?

By the way, keep up the hard work, @gnif it’s looking great and I’m looking forward to seeing the more recent version running!

UPDATE: Ok, I figured out my spice keyboard mouse issues. I had another VM auto-starting that also has spice integration. If this vm starts before the LG VM apparently spice doesn’t work in the LGVM.

Install binutils-dev, this is documented. Please be sure you follow the instructions provided on the official Wiki over at:

This is not a LG issue, it is simply using the SPICE protocol to send keyboard/mouse input, the VM still needs a virtual KB & Mouse, as well as the SPICE server. Ensure you still have a virtual display connected but in the type selection type none (it will accept this). libvirt stupidly assumes that you don’t want SPICE if you remove the virtual display.

Thanks mate, life is holding me back a little the last couple of weeks, but I should be able to dump some more time into the project soon. There are some very exciting changes on the way that improve performance 2 fold, as well as huge improvements to mouse/keyboard interaction.

Likely port contention, you can tell SPICE to listen on different ports/sockets in these scenarios.

1 Like

@gnif I have the same problem on Arch: looking-glass-client: error while loading shared libraries: cannot open shared object file: No such file or directory. However binutils is installed and on Arch there are no split packages like binutils and binutils-dev as far as I know. Since the build packages are listed for Ubuntu I build the client on Ubuntu and copied it to my Arch system, but I do not know which Arch packages I need for just running the application :thinking:.

That’s a BIG NO-NO. You NEVER move dynamically linked objects from one distro to another. The dependencies (and in many cases even symbol tables) are completely different. The only executables you can transfer safely across systems are statically linked relocatable ones, and LG is not one of those.

I was told that on the Discord already and compiled the binary again. Works now.